Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

There's a setting in full screen zoom called 'follow text focus', which is supposed to cause OSX to follow the position of the text caret instead of the mouse pointer when in full screen zoom mode.

The problem is it doesn't work very well.

I have a 2 monitor setup for my main Mac, but the second monitor is a wacom cintiq and it is only on when I'm using it to draw. The rest of the time it's off. This means that full screen zoom needs to be in "Continuous" mode. If you have it in "Keep cursor in the middle" mode then the cursor ends up at the edge of my main monitor most of the time, or off it altogether.

However, the text cursor behaviour can't be influenced at all, and in "follow text focus" mode it will just fly off the edge of the monitor, even in apps where following the text focus works.

In Microsoft Word 2011, text focus follow doesn't seem to work at all!

I'm trying to find some kind of solution that will suit, but am stuck so far.

I think if I can get OSX to act as if the cintiq isn't even attached when it's off that might help to some degree. However, the only way I know of doing that is physically disconnecting either the display's power, or disconnecting the DVI cable. Neither of these are really an option as the connectors aren't exactly in accessible locations. If there's some way of getting OSX to go into single monitor mode when the cintiq is off then I'd love to know what it is.

Even this wouldn't fix the problem with Word and other apps that don't honour the text focus following. Is there anything I can do about them?

share|improve this question
add comment

1 Answer

I can't help you with Word, etc., but here's how to get it to stop recognizing the Cintiq:

  1. Go to System Preferences.
  2. Open the Displays pane.
  3. Click "Detect Displays."

If the Cintiq is turned off, this should fix it. When you want to re-detect it, simply turn it on and Detect Displays again.

If you want a quick way to access Detect Displays, there's a menu bar icon that can be enabled for Displays tools while you're in the same preference pane: Tick "Show displays in menu bar" and you can have quick access to that as well as a few other relevant things.

share|improve this answer
    
That didn't work, the Cintiq still shows up as the second monitor. It only goes away if it's completely powered down, or disconnected. –  GordonM Jan 19 '12 at 6:55
    
Oh, darn. Sorry, and good luck! –  timothymh Jan 19 '12 at 20:42
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.