Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

For a while (long enough that I almost finished writing a very long SE question about it), I thought Google Calendar wasn't syncing with iCal. Then, I realized that it in fact was, but all the calendars were cleverly hidden in the Window menu, just above Bring All to Front. If I click one of these, the calendar displays—in its own window. All the events are there, but ry as I might, I can't get any two calendars to display in the same iCal window! It's very irritating.

share|improve this question
    
I'm running Lion. –  timothymh Jan 18 '12 at 2:25
add comment

1 Answer

up vote 4 down vote accepted
+50

Google calendars other than your default calendar are treated as delegated calendars by iCal. To get them to open in the main screen go to iCal > Preferences > Accounts, select your google account, click the tab for Delegation, then check the boxes next to the calendars you want to display in your main calendar window.

Now in the upper left hand corner of the iCal window, click the Calendars button which brings up the pop-up allowing you to select which calendars are visible. Check the box for the calendars you want to view. You can return to this pop up at any time to change the calendars you're seeing at any given time.

Screenshot

share|improve this answer
    
Thank you—but it's not set up through CalDAV. It's simply set up as a Google account with calendars enabled. Should I switch it to CalDAV? –  timothymh Jan 29 '12 at 22:50
    
Oh, wait, never mind. I thought the place I would access the "Delegation" list was in System Preferences. –  timothymh Jan 29 '12 at 23:00
    
It worked! I'll give you the reputation in 22 hours. :) –  timothymh Jan 29 '12 at 23:01
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.