Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I recently upgraded to a Wireless-N capable router (Linsys WRT160N) from a Wireless-G model. Everything was fine and dandy with the G, but I needed a stronger signal strength in my living room and dining room. After getting the new router configured and deconflicting the channels, it's finally working great with my Macbook, Galaxy Nexus, and wife's iPhone 4.

The Macbook, however, refuses to reconnect to my network after closing and opening the lid. It connects fine once you select the network from the list of available ones, but it has never done so on its own. I've made sure that my network is at the top of the preferred networks list in the Advanced menu in the Network settings, but that still has no effect.

Am I missing something?

share|improve this question
add comment

3 Answers 3

up vote 1 down vote accepted

The most common solution to this problem (I encountered numerous times) is to change the WiFi channel on your router.

If your router is set to auto channel you can switch to channel 6 or 11 for example.

And try different channels.

share|improve this answer
    
This worked! Tried everything else, and a few different channels, but finally channel 3 worked. –  Spaniard85 Jan 18 '12 at 0:18
    
Glad I could be of any help. This happens particularly when you are using a computer bought in (or configured for) one country and used with access points or routers from another... I travelled a lot and I I have access points from different countries with gear from multiple countries... it's a mess and I have to juggle with this problem a lot. –  Coyote Jan 18 '12 at 10:15
add comment

Start by creating a new network location to see if the issue is replicated. Here's how system pref/Network

If that fails then you can remove the System Configuration folder to the Trash and restart the computer, which then creates a new System Configuration folder. Macintosh HD/Library/Preferences/System Configuration

share|improve this answer
add comment

In the Advanced configuration for the Wifi Network Configuration, theres a checkbox that says "Remember networks this computer has joined"

If that is unchecked, one consequence is that WiFi will see and recognise your wifi network, but will never join it unless you tell it to, which sounds like your issue down to a T.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.