Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I have an iPad 2 with iOS 4 and the Facebook for iPad app installed.

Even after disabling all the Push Notifications from Settings > Facebook > Push Notifications, I still get push notifications.

Is this a bug in either Facebook or Apple's part or is there a hidden setting somewhere to disable the notifications?

share|improve this question
    
Have you tried an uninstall - reinstall? –  Graeme Hutchison Jan 17 '12 at 14:47
    
Yes. I've tried that but still it keeps coming up. –  ptamzz Jan 17 '12 at 19:31
    
Sorry there isn't a lot more I can suggest, hopefully you will find the answer. Would you consider upgrading to iOS5? –  Graeme Hutchison Jan 18 '12 at 9:45
add comment

2 Answers

There were some bugs in the FB app for notifications, but you should be able to disable the notifications on an app-by-app basis in at the iOS level from Settings -> General -> Notifications (or Settings -> Notifications ... I don't have an iOS 4 device handy to double-check).

share|improve this answer
    
I'm not sure as I could not find any settings for notifications under Setting>General>Notification. Instead, on the left pane itself, scrolling down, there's a section called 'Apps' under which Facebook App is listed, inside which I'd disabled the push notifications. So the path is like Settings>Facebook>Push Notifications. But still the problem is there. –  ptamzz Jan 17 '12 at 19:41
    
I think the iPad has a 'Notifications' section in the left pane (I think it was there in iOS 4), if you select that, you should be able to toggle off the notifications from Facebook completely. The settings found under the Facebook app section will only take effect after you have opened the app after changing them, but I've always found these to be quite unreliable. –  Mike Insch Jan 19 '12 at 14:22
add comment

I had the same problem. You have to ALSO go to Settings->Notifications within the iPad app and turn off Notifications there AS WELL.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.