Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have been using my iPad with Numbers and would like to be able to just open them up on my Mac with Lion. I can not figure out how to connect/sync to iCloud documents. I have checked iCloud documents for syncing, but my documents don't appear on my Mac. I have even set up my mobile documents folder on the desktop. I can drag files to the iCloud that way, but then I can not open them from that folder. Frustrating.

share|improve this question
Also see… – bmike Feb 22 '12 at 21:29

Unfortunately, Macintosh does not (yet) support complete iCloud synchronization for documents. We can only hope that Apple will implement this at some point soon.

In the mean time, go to and sign in. You can drag documents to and from the appropriate section on your computer, and it'll work with your iPad. There's still another bug, which involves Mac > Mac syncing, but as long as you just do iPad > Mac or Mac > iPad, it'll work fine. :)

Also, there is a folder located at ~/Library/Mobile Documents/ which contains your iCloud-enabled apps' data. This includes the iWork suite, but unfortunately iWork documents aren't saved as the normal filetypes (e.g. ".pages"), so they can't be opened on their own.

share|improve this answer
Update to this: the upcoming OS X 10.8 (Mountain Lion) sounds like it will add the desired capability to iWork et. al. – Dan J Feb 23 '12 at 3:42
Thats awesome! Can't wait. Thanks, @djacobson! – timothymh Feb 23 '12 at 12:57

The following works on Lion 10.7.4:

Warning! If you don't know what you are doing, then you probably shouldn't be doing this. You take all responsibility for nuking your own iCloud data.

  • As usual, make sure you have iCloud setup for your user and enable Documents & Data sync.

Execute next steps from Terminal (/Applications/Utilities/Terminal):

  • run: sudo nano /System/Library/LaunchAgents/ - change RunAtLoad from false to true
  • run: defaults write kUBSyncEnabledKey -bool true

At this point, ubd needs to be restarted..

  • run: launchctl unload /System/Library/LaunchAgents/
  • run: launchctl load /System/Library/LaunchAgents/

now ~/Library/Mobile Documents should be synced up.

If for some reason it's still not syncing after step 4, try logging out and back in.

share|improve this answer
Confirmed this works. – Andrew Ferrier Sep 9 '12 at 21:40
Yep, that worked! Thanks! – Sascha Galley Jan 3 '13 at 15:44

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.