Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

From time to time (in fact very often) my iPhone will stop displaying the lock screen "now playing" info, and subsequently the controls won't be there.

I can still start the music app playing something, but I can't pause or skip tracks.

The same thing can be seen if I try to use the multitasking audio controls (swipe "left" on the multitasking bar). The play/pause button won't stop audio playback. Can't skip.

Same problem with the headset remote buttons. Can often start audio playing (although what it'll play is random). Can not stop/pause, can not skip.

I've not been able to reproduce this reliably, but it happens often. The phone is in this state more than it isn't. A restart resolves this most times.

How to fix?

share|improve this question
It's isnt rally an answer, but this happens to me ALL THE TIME on my ipad 2 32gb and it works every week or so.. But my ipad IS in fact jailbroken so that might be the problem.. The reboot worked but only for a few hours.. Thanks :) – user45264 Mar 16 '13 at 2:36

Possible Causes:

  • Mobile substrate add ons on a jailbroken device
  • Corrupt event handling events
  • Loss of data with streaming services
  • Accessory interference
  • Airplay
  • Older version of iTunes

Several things to try:

  • If you are jailbroken try booting into safe mode (SBSettings Feature).
  • If problem is with data streaming app then try the iPod app.
  • If accessories are connected, disconnect them.
  • If the problem persists, restore to the latest version of iOS and update iTunes.
share|improve this answer
Not jailbroken, not streaming, not using airplay, iTunes and iOS is latest (10.5.2 and 5.0.1), no accessory needed to trigger this. – johani Jan 16 '12 at 16:49

Do a hard reset. Hold the sleep/wake button and home button together until the phone turns itself off and keep holding the power button for a few extra seconds but let go of the home button as soon as the phone turns off.

Wait about 3 minutes. Turn your phone back on.

Now, open the multitasking tray and quit everything that is open.

If this works, then problem solved, if not, try a restore in iTunes. If that helps then problem solved, if not, go to the Genius Bar.

share|improve this answer
I'm attempting this. Did the hard reset as described yesterday. As with previous restarts of the phone the problem went away. Will update in a few days to see wether it "stays fixed" or not. – johani Jan 18 '12 at 14:59
This didn't work. Soon only a full restore is the only thing I haven't tried. I'd prefer not to as it would take hours to do. Will see where I go from here. – johani Jan 23 '12 at 9:08

It's a bug: only Apple can solve it with an update. It's not iTunes — it happens to any app you can listen music with, for instance I use YouTube but I can't pause/skip either, but I do remember that it worked till I fully turned it off. It could be that it changes if you turn off your iPhone and then turn it back on again. I would give this a try if I were you.

share|improve this answer

I was facing the same issue. A restart fixed the problem.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.