Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I use Safari and Firefox. To be able to view PDFs on Firefox on the fly, I use the Schubert's PDF viewer. But, I would like to block it from loading my PDFs on Safari. I like Safari's way of handling PDFs a bit more. How can I disable a particular plugin on Safari?

Thank you.

share|improve this question
add comment

2 Answers 2

I found a workaround. Move Schubert's plugin file which is located in:

/Library/Internet Plug-Ins/PDF Browser Plugin.plugin

or

/Users/YOUR_NAME/Library/Internet Plug-Ins/PDF Browser Plugin.plugin

to

/Users/YOUR_NAME/Library/Application Support/Firefox/Profiles/YOUR_PROFILE_DIRECTORY/plugins/

If you don't have plugins directory - create it. That's all :)

For Opera users - they should move plugin file to:

Library/Internet Plug-Ins/Disabled Plug-Ins/

Firefox and Safari don't use plugins from this location, but Opera does :)

share|improve this answer
add comment

For that plugin (which is not a Safari Extension which is handled differently), you have to uninstall the plugin manaully by deleting the file, whcih means you don't get the plugin in Firefox

the support site says.

How do I uninstall PDF Browser Plugin? In Finder go to /Library/Internet Plug-Ins/ or /Library/Internet >Plug-Ins/ and move PDF Browser Plugin to the trash. Then restart your web browser.

Edit: Looking at how the plugin is done, it is installed in Internet plug-ins which means it is Global. I have looked to see if Firefox will load it from another location but have been unable to get FF to do that.

I've looked at extensions for both Firefox and Safari (such as ClickToPlugin) however you cannot disable a plugin in Safari as you can FF.

So my answer is that it cannot be done with Safari and global plugins.

share|improve this answer
    
That's the thing. I would like to keep it on for Firefox, but not have it interfere with Safari. –  morgoth_bauglir Jan 16 '12 at 15:22
    
I think the solution is to place the plugin in a location that only Firefox looks for and not Safari, i'll look into it further –  Stu Wilson Jan 16 '12 at 16:31
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.