Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Not sure where to address this issue, though, this Apple Mail (bug?) is incredibly annoying.

example input

Searching for something brings the same email 100 times, +thousands of bin entries. Why this behavior? How to fix that? It simply makes impossible finding any emails.

After the last update, it became even more annoying. Now it shows "Deleted Messages" as well.

enter image description here

Those aren't even actually deleted messages. They are trash of autosave process.

share|improve this question
    
have you deleted the email from the bin folder? –  Graeme Hutchison Jan 15 '12 at 20:05
    
There are thousand versions of the same email in the bin folder every time I compose any. This looks like some buggy auto-save behavior. –  Guy Jan 15 '12 at 21:00
    
What type of email account is this that you have hooked Apple Mail up to? Who is the service provider (Google Gmail, AOL, Comcast, etc.)? Is it configured for POP or IMAP? Very likely it the problem results from a combination of configuration settings on both the email provider end and the Apple Mail end. If you will name the provider and the type of email account, it will help in troubleshooting. –  Wheat Williams Jan 16 '12 at 17:25
    
It is Google (google.com/a), and it is configured over IMAP. –  Guy Jan 16 '12 at 20:05
    
Not any help, but I've heard a few people complain about this continuous autosave bug, specifically with Google accounts. Not sure if it's Mail.app or Google's rather unique take on IMAP that's the problem, though... –  scottishwildcat Feb 19 '12 at 16:44

2 Answers 2

up vote 5 down vote accepted

When you create an email Mail.app saves a draft. When you type a few more letters Mail.app deletes the old draft and saves a new one.

If you have "store draft messages on the server" selected (Preferences -> Accounts -> (select account) -> Mailbox behaviours) then every time you make an edit Mail.app sends it to Google then deletes any old drafts. Unfortunately, Google doesn't really delete the old drafts. Instead it moves them to the Bin folder and when you search in Mail.app it finds these hundreds of old drafts.

To stop this occurring on future drafts uncheck "store draft messages on the server" for all my Gmail accounts.

To clear up your old drafts log into to Gmail directly and: * Go to the All Mail folder and manually select and delete all the old drafts * Go to the Bin folder and select "Empty Bin"

share|improve this answer
    
The answer that is checked was helpful but this turned out to be the answer to my problem. –  Jay Oct 26 '12 at 16:15

Empty the trash and try "Mailbox -> Rebuild".

share|improve this answer
    
Don't know whether that's permanent fix, but certainly makes things work better now. –  Guy Feb 19 '12 at 18:47

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.