Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I asked this question months ago and I finally had a chance to try the answer. I followed the instructions in the answer but it didn't work. After I copied over the iTunes folder from Windows to Mac as per the instructions, when iTunes starts on the Mac, I see all of my music listed. But iTunes can't locate any of the songs and throws this error: 'The song “Hard Days Night” could not be used because the original file could not be found. Would you like to locate it?' Doing a get info shows that iTunes thinks that the file is located here: file://localhost/192.168.1.6/music/HardDaysNight.mp3

So clearly the path is incorrect. The correct SMB path is smb://192.168.1.6/music/HardDaysNight.mp3. How do I fix this?

I cleared out the iTunes folder and simply added the file directly to iTunes. iTunes copied the file from the network directory to the local hard drive which is not what I want. I want to keep my files on the network folder. How do I replicate what I had on Windows on the Mac where iTunes references music stores on a network drive?

share|improve this question
    
How does your mac see the path to the network files in the Finder? –  Mark Jan 15 '12 at 17:25
    
I mounted the network folder on the Mac via Finder > "Connect to Server". It appears as an icon on my desktop. But the mount path is /Volumes/Media/Music. –  Sajee Jan 16 '12 at 1:14

2 Answers 2

The problem as I understand it is that windows and Mac refer to file locations differently. So with that in mind, if you intend on moving the music to your Mac, then your best bet is to just create a new library file on the mac, adjust the location of music in the presences to your network drive, then re-add all the music to iTunes. This 'should' fix everything.

Any time I tried to share my library between operating systems, I spent more time trying to fix it than it was worth. Now I just keep a copy on both machines and use home sharing and iCloud to keep them in sync.

Good luck, hope this helps.

share|improve this answer

Here's what finally worked.

  1. Copy the file "iTunes Music Library.xml" from Windows to somewhere on your Mac, like your desktop.
  2. Change all references to network location of the audio files to something the Mac can understand. For example, all of my MP3 files started with file://localhost//192.168.1.6/music/ So I did a Find & Replace and changed them to the path the Mac mounted my remote music folder: file://localhost/Volumes/Media/music/
  3. Clear out the iTunes directory in ~/Music.
  4. In iTunes > Preferences > Advanced, uncheck "Copy files to iTunes Meida folder when adding to library".
  5. Then import the XML file from step 1 into iTunes by File > Library > Import Playlist.

The "Re-creating the iTunes Library file" section near the bottom of this article helped.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.