Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

When I chat with two of my friends (say A. and T.), our iPhones use text instead of iMessage. It used to work using iMessage, but one day, it switched to text. A, T and myself otherwise use iMessage with other contacts without any problem. It's only A <-> me and T <-> me which uses text.

How do I reset iMessage in order to re-enable it with these two friends?

Thanks.

share|improve this question

5 Answers 5

Try disabling iMessage in Settings → Messages → iMessage. Turn it off and then turn it back on. After doing this, close all apps and restart your phone by holding down the Lock button and the Home button for ten seconds. If this does not resolve the issue, it may related to the other users' devices.

You can also try restoring your iPhone though iTunes and setting up as a new device if you don't believe it's related to the other users.

share|improve this answer

If you're using Sprint and Google Voice, see this support article from Apple: http://support.apple.com/kb/TS4091

Summary:

Integrating your Sprint account with Google Voice may prevent your mobile phone number from being registered for use with FaceTime video calls and iMessage text messages.

This occurs only when your Sprint phone number and Google Voice number are not the same. It should not affect your ability to send or receive SMS or MMS messages, or to receive or place FaceTime calls or iMessages using an email address instead of your phone number.

The support article doesn't give a solution, but I infer that you would need to change something with respect to Google Voice. I don't have a Sprint account and I don't know what it means to integrate a Sprint account with Google Voice.

share|improve this answer
    
Please summarize or excerpt the article in the answer. The idea is to make the answer stand alone, so that it is still valuable if the link breaks. –  Nathan Greenstein Jan 14 '12 at 20:38

You can delete the SMS messages from the conversation and just leave the iMessages. Then reset your phone using the sleep/wake + home buttons. This has restored the default to Send via imessage again for the conversation.

share|improve this answer

I just had the same issue (also with a person named "A") and was able to resolve it by sending an iMessage to A.'s email address, which she had registered to receive iMessages. She received it fine. That seemed to wake her iPhone up to the fact that I was sending from an iMessage-capable number, as she was then able to send me an iMessage to my mobile number, where just minutes before it didn't work.

We then repeated the procedure in reverse (she iMessage'd my email address). Now we are both able to send each other iMessages to each other's mobile number.

share|improve this answer

Go to Settings > General > Reset > Reset Network Settings. This reset my iPhone back to iMessages when it got stuck in a rut sending text messages to another iPhone user.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.