Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I've searched the web for a method to type an "É" character with a french keyboard layout in firefox.

It appears I'm supposed to type +E, and then +E to achieve this, but as soon as I press and E simultaneously, an

ê

character appears. Why, and what should I tried instead?

I'm using Lion.

share|improve this question
    
Dead simple? How are you even supposed to think that hitting caps lock would make any sense ever? –  Debilski Jan 13 '12 at 16:13
    
@Debilski: dead simple to use != dead simple to discover. But it is a really normal behavior for a key named "capitals lock" –  greg0ire Jan 13 '12 at 16:24
    
Well, you’re probably correct. It does make sense in a way. I think I must have never thought about the real meaning of the word. –  Debilski Jan 13 '12 at 16:32
    
I didn't either until I first saw this behavior on linux. Because I'm not an native english speaker. Then I re-analyzed what Caps Lock means, and what Shift means. –  greg0ire Jan 13 '12 at 17:15
add comment

6 Answers 6

up vote 4 down vote accepted

French layout?

  1. Press caps lock .
  2. Press the é key (that's the 2 on a QWERTY).
  3. Press caps lock again.

But you need to make sure you're using the French layout, and not French - numeric (“Français - numérique”, French flag with “123” beneath it).

French keyboard layouts in Mac OS X

Otherwise, you're explicitly asking the system to use the caps lock key as a shift lock for the numbers bar on the top of the keyboard!

share|improve this answer
    
As I already said, this gives a 2, which is also the stupid behavior of Microsoft Windows. This works on Linux. Maybe this is configurable... if yes please tell me how. –  greg0ire Jan 13 '12 at 13:07
    
That's because you're using the “Français - numérique” layout (French flag with “123” beneath it) instead of the “Français” layout (French flag only), aren't you? –  MattiSG Jan 13 '12 at 13:12
    
I think the numeric version is the one which emulates the ancient French typewriter layout. The one which did not have any capital accented letters at all. –  Debilski Jan 13 '12 at 16:13
    
To do it more smoothly you can keep caps lock pressed. –  reg Sep 8 '13 at 20:42
add comment

To type this character, type +E, then +E. "É" is the character I get.

In Lion, I understand one can hold down the key, a la iOS, and get a list of possible characters with accents for many of the keys:

enter image description here

share|improve this answer
    
Yes, in Lion you hold Shift+E in that case. –  gentmatt Jan 13 '12 at 9:27
    
I edited my question. –  greg0ire Jan 13 '12 at 9:31
    
@greg0ire You should only type and hold Shift+E. Does this not work? –  gentmatt Jan 13 '12 at 9:38
    
Holding Shift+E displays EEEEEEEEEE. Testing in firefox. –  greg0ire Jan 13 '12 at 10:44
2  
Try textedit, Chrome. Firefox might not support this (already). –  bouke Jan 13 '12 at 11:00
show 4 more comments

You can use Edit menu and press Special Character (option + Command + T) and from opening window go to Latin tab and find É.

enter image description here

enter image description here

share|improve this answer
    
I know about this method, but I'm searching for something more simple. On linux, I just type <kbd>Caps Lock</kbd>, then <kbd>é</kbd>, and I'm done. On Mac OS, this gives me a 2 (on windows too). –  greg0ire Jan 13 '12 at 9:27
    
I suggest this solution because I can type É when I first press option+e then shift+e, I must mention that I have OS X lion. –  Am1rr3zA Jan 13 '12 at 9:45
    
I'm using OS X lion, and my main problem is to know why you can do this and I can't. –  greg0ire Jan 13 '12 at 10:41
add comment

The standard dead-key combo for a French layout is + Shift + &, then Shift + E.

share|improve this answer
1  
Oh this is sooooo handy! 5 keystrokes! What a nice OS! Anyway, thank you very much for this answer. Upvoted, accepted! –  greg0ire Jan 13 '12 at 13:03
    
@greg0ire Haha! That really is a lot of effort needed for such a letter. Maybe you should create a new question and ask if you can assign a shortcut for those five keystrokes? –  gentmatt Jan 13 '12 at 13:12
    
@gentmatt: Thank god, there's a reasonable, Linux-like solution! I don't know why this computer was configured that way. It's brand new, so it must be the default... strange. –  greg0ire Jan 13 '12 at 13:23
1  
I think the reason it is so difficult is the idea some French language experts have that you don't need to ever show accent marks on capital letters. Seems totally crazy to me when it comes to digital text. –  Tom Gewecke Jan 13 '12 at 13:55
    
@TomGewecke but see academie-francaise.fr/la-langue-francaise/… for a rather authoritative counterargument. –  Daniel Lawson Sep 9 '13 at 5:24
show 1 more comment

in Lion just hold e or if you need in uppercase hold Shift + e and you will have an option pop up

share|improve this answer
    
Doesn't work for me. I have tested this in firefox search box, and in gmail's search box. –  greg0ire Jan 13 '12 at 10:43
    
Lion’s keyboard now brings up a palette that lets you choose an accented or alternate character. defaults write -g ApplePressAndHoldEnabled -bool (true|false) Hit Return, log out and back into your account. Have also tested this in Chrome and it works for me. Can you confirm if it works outside Firefox? –  osx86x Jan 13 '12 at 10:50
    
Could you please edit your answer or your comment and use backticks to show the command line? I'm having trouble seeing where it starts... Does it really start with -g ?!? –  greg0ire Jan 13 '12 at 10:54
    
Also forgot to mention that it only works for the default English keyboard layout (not all apps support this and hence may not be system wide) –  osx86x Jan 13 '12 at 10:57
    
My keyboard layout is french, so this command isn't worth trying, is it? –  greg0ire Jan 13 '12 at 10:59
show 1 more comment

In French grammar, the rules are that there are no accents on upper case letters. This error was introduced with Microsoft word which enforced accenting upper case letters and was fixed since then. The rules never changed and it is still grammatically wrong to put an accent on an upper case letter in French.

share|improve this answer
    
So what about this: academie-francaise.fr/la-langue-francaise/… –  TomG Dec 22 '13 at 12:55
    
@Aude Robinson : Any source to back up this ? I don't believe you at all. –  greg0ire Dec 22 '13 at 16:08
    
@greg0ire Indeed, I think it is nonsense. My copy of Grevisse, a 1000+ page French grammar, is full of accented capitals. I believe the Imprimerie Nationale requires accented capitals. –  TomG Dec 22 '13 at 23:56
    
@Aude Robinson: I think you should delete your answer. –  greg0ire Dec 27 '13 at 13:18
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.