Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I setup a new lion server, with fully functional dns. Forward and reverse work without issue. I have a forward DNS entry for the server externally. OD is running, and there's 5 network users. Also, all the correct ports are forwarded on the firewall.

AFP works Flawlessly for all users internally and externally, and when the admin logs into the server with WebDAV, it works fine. Using finder, we use this method: http://server.abc.com/webdav

However, the network users can NOT connect, but the local accounts can. Does anyone have any clue? Has this happened to anyone else?

share|improve this question

2 Answers 2

I've written a blog post on how to do this.

  1. From Server Admin, make new Web > Realm and set appropriate ACLs.

  2. Create a folder in location/volume where data for Share is physically located.

  3. Change permissions of folder to _www:admin (that’s what works for me)

    $ sudo chown _www:admin /Library/Server/Web/Data/Sites/host.domain.tld

  4. Create a symlink to the share folder in the folder where your web server looks to for the domain’s data.

    $ sudo ln -s /path/to/data /Library/WebServer/Documents/site_web_folder

I know there probably a bit of information missing and if I showed images of the actual steps it might make things a bit clearer but I’m a little paranoid about my server and I don’t want to risk opening it up to further attack.

All this needs to be done before OS X will allow a "Connect to Server..." and mount your WebDAV share.

share|improve this answer

I searched for quite a while to find the answer to this. Finally found an article on the apple site that is EXACTLY the answer.

http://support.apple.com/kb/HT4777#

Some additional hints: For ease, enable the root user on your server and then login as root before you begin. http://support.apple.com/kb/HT1528

Also, make sure to use a command line editor OR change the prefs in TextEdit to ensure the files are saved correctly.

Finally, to find the files in the first place you will have to make hidden files visible.http://guides.macrumors.com/Viewing_hidden_files_on_a_Mac

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.