Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

My console is flooded with messages like these:

11.01.12 21:21:39,819 com.apple.usbmuxd: _SendDetachNotification (thread 0x7fff7f6cb960): sending detach for device d0:23:db:3e:0b:82@fe80::d223:dbff:fe3e:b82._apple-mobdev._tcp.local.: _BrowseReplyReceivedCallback got bonjour removal.
11.01.12 21:21:46,596 com.apple.usbmuxd: _SendAttachNotification (thread 0x7fff7f6cb960): sending attach for device d0:23:db:3e:0b:82@fe80::d223:dbff:fe3e:b82._apple-mobdev._tcp.local.: _GetAddrInfoReplyReceivedCallback matched.
11.01.12 21:21:46,729 usbmuxd: _AMDeviceConnectByAddressAndPort (thread 0x100781000): IPv4

They always happen in this combination of three messages and around every 10-30seconds

Any suggestions where this is coming from and how to fix/disable it?

Edit: (additional Infos)
Ok it seems to be originating from my iPhone (MAC d0:23:db:3e:0b:82)...

There are no Wifi-Printers or anything like that in the Network.
And the Messages are still there when all USB Devices are disconnected.

Edit2:
This seems to be coming from iPhone Wifi-Sync, is there any way to get rid of this spam without diabling Wifi-Sync for the phone?

share|improve this question
    
Do you have a USB or network printer attached to the machine? –  Matt Love Jan 11 '12 at 20:53
    
No. And even if I unplug all USB devices this message is still showing up in the console. –  bardiir Jan 11 '12 at 20:54
    
OK. Do you have an iPhone? If so, can you look under Settings>General>About and tell me what your Wi-Fi Address is? Also, can you go open /Applications/Utilities/Network Utility.app, under the Info tab select your default connection method and tell me what the hardware address is? Also, do you have a wireless printer in the area? –  Matt Love Jan 11 '12 at 21:00
    
It seems to be originated from the iPhone (the MAC in the message is the one used by the phone, nice call on that). My Airpot uses 00:1d:4f:ff:a2:5b as it's MAC. There are no Wifi-Printers –  bardiir Jan 11 '12 at 21:09
    
Do you sync your iPhone over WIFI with iTunes? –  Matt Love Jan 12 '12 at 0:34

6 Answers 6

up vote 7 down vote accepted
+50

Open Console and highlight the usbmuxd spam, then click [ignore sender] in the toolbar:

usbmuxd

To re-enable usbmuxd spam, click the [^] symbol in the lower bottom left corner then (x):

usbmuxd


This will allow you to safely ignore any Console spam you would like without actually disabling anything other than the message that you see in Console.

share|improve this answer
1  
This isn't a perfect solution as it may disable some relevant bug messages from usbmuxd too but it's probably the best solution at the moment. Thanks :) –  bardiir Jan 21 '12 at 8:06

What is also interesting is that this is last entry I see in the console before my Mac hangs (well it's the last entry I see before the reboot messages). Could be a coincidence, of course, because there are so many of these messages. I've tried disabling usbmuxd to see if it is relating to the hanging problem.

I moved /System/Library/LaunchDaemons/com.apple.usbmuxd.plist to ~/Documents and restarted. You can move it back and restart to get it running again.

share|improve this answer
    
same for me. i am getting lots of crashes and time when my mini wont wake up. This is always the last thing in the logs. Did disabling it stop the crashing? i just turned off wifi sync for my iPhone, we'll see if that helps. –  Mike Ohlsen Mar 4 '12 at 20:24

The _apple-mobdev._tcp.local. is an mDNS message (aka bonjour) and is being broadcast on your network from an iPhone.

You can see it being broadcast on your network by running:

dns-sd -B _apple-mobdev

on any Mac. It is the iPhone advertising it can be attached to.

share|improve this answer

Something is wrong with the way OS X / iTunes handles the wifi sync to the 4S. Connect it by cable and drag a few songs to it, let it sync via wire, and the console messages should disappear after that..

Hope its fixed in a software update.

share|improve this answer

These messages disappear when you disable wifi sync for your iDevices. This is really annoying me, too, because I like wifi sync, but the log becomes useless with all the usbmuxd spam.

share|improve this answer
    
Yep this is the problem, is just don't know how to get rid of the spam without disabling wifi sync... –  bardiir Jan 15 '12 at 18:28

You can always edit your /etc/syslog.conf file to send messages from usbmuxd to their own private log file. If you never want to see them, send it to /dev/null.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.