Sign up ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I'd like to be able to give certain people my IP address (24.178.XX.XX) so they can access port 80 on my machine from their browser.

Right now just putting that IP address from my own browser doesn't connect to anything...just says it can't find the server.

So is there some setting I need to enable?

I have an AirPort Extreme.

share|improve this question
Assuming everything else is properly configured: if you reconfigure your HTTP server to listen to, say, port 8080, will it work? Your ISP might be blocking ports 0-1023 from outbound traffic, which is not entirely unheard of. –  koiyu Jan 11 '12 at 16:54
If you don't get a good answer here, you might try –  Nathan Greenstein Jan 11 '12 at 17:00

3 Answers 3

Within the Airport Utility, you have an option for Port Forwarding (or even setting up a DMZ Host if you want all unsolicited incoming traffic to go to your web server, however this is unadvised for general security as it is best to only allow what you need to reduce attack vectors).

Using this option, you can set up a port mapping between port 80 on your external interface to port 80 on the NAT IP address of your internal web server.

This will provide immediate access to your server over port 80 to the outside world.

That however assumes that you already have a web server properly configured to deliver data over port 80.

A good first step there would be to use the Web Sharing setting under "System Perferences -> Sharing" to see whether this meets your needs. It will also enable you to do an immediate test to make sure that everything is working.

If you need something a little more comprehensive than what you are provided within the OS X client, look at OS X Server ($50 on the App Store) or MAMP (free and paid offerings).

share|improve this answer

You can use iptables to redirect user to port 80 when they open your IP on their system

Eg. It will redirect the requests on port from 8080 to 80. Since to access the port below 1024 you need to be super user. So, you can allow the user to connect to port 8080 and redirect to port 80

/sbin/iptables -t nat -I PREROUTING -p tcp --dport 8080 -j REDIRECT --to-port 80
share|improve this answer

lets make some assumptions - since you're using port 80, you want web traffic... you need to run a web server on your computer that will be listening on port 80, thats the default port for web traffic. good examples are MAMP -

share|improve this answer
I've got a web server running. That's not the issue. I'm saying my IP address doesn't connect to anything, it's like the IP address doesn't exit. –  Shpigford Jan 11 '12 at 16:23
your firewall blocks any incoming traffic from the internet. you will need to a)obtain your computers IP on the inside, usually 192.168.x.x b)configure your airport to allow port 80 traffic to your inside IP address. –  DBR Jan 11 '12 at 16:24
Firewall is off and 192.x.x.x wouldn't be accessible externally, which is what I need. –  Shpigford Jan 11 '12 at 16:25
firewall off doesn't help. you need to configure port forwarding on the airport. tell the router that when someone tries to reach traffic on port 80, it needs to know which internal IP to send data to. –  DBR Jan 11 '12 at 16:29
see steps 1-6… after you're done, you can check by entering your public IP in your own browser. Also check that your local web server is running by entering your private IP in your browser as well. –  DBR Jan 11 '12 at 16:32

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.