Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Every time I login to my Mac (Lion OS X) I keep getting this windows shown, even when I shut down without the option of reopening the windows when I log back in from here:

enter image description here

This is the window that keeps showing:

enter image description here

How on earth do I stop this for appearing all the time when I login?

share|improve this question
Is it open when you shut down? – Gerry Jan 11 '12 at 12:30
No, I always close everything before I shut down and I uncheck the reopen windows on login. – MacMac Jan 11 '12 at 12:34
up vote 3 down vote accepted

I had the same problem, with the same folder. The folder is within the Steam application bundle, and for some unknown reason it gets added to your Login Items.

To stop it showing up when you login:

  1. Open System Preferences
  2. Click the Users & Groups icon
  3. Select the Login Items pane
  4. In the list of items, select the MacOS folder
  5. Click the "-" button to remove it
share|improve this answer

As the Finder window is showing the content of an application bundle, I think that application is trying to automatically execute a file at login, but it used the path to that directory, instead of the file that should be executed. The fact there is a file could confirm my idea.
The checkbox you see on that dialog box applies only to applications you open yourself after login, and which are still open when you restart/shut down the computer. As far as I experienced, the Finder windows that were open before to restart/shutdown my Mac are re-opened when I log in, even if I don't select that checkbox.

Look for any place where an application can register a file that is automatically opened/executed at login, and remove the reference to that directory.

share|improve this answer

1) Go to ~/Library/Preferences. ~is an alias for your username.

2) Delete the file

3) Restart.

share|improve this answer

You have Steam installed, which for some reason adds that folder to you Login Items list. Go to System Preferences:Users & Groups:Login Items and remove the Steam item from the list.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.