Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm not using Mac keyboard however it did work properly before. I changed the Command key to my Ctrl-key. Until today, using this Ctrl key yield extremely odd characters. When pressing Ctrl-A yields å Ctrl-V yields √ Ctrl-C yields ç

And I have no idea where do these characters come from? So how could I fix this issue? Can anyone please help? Thanks.

Here is my screenshot

enter image description here

share|improve this question
up vote 3 down vote accepted

It looks like you have accidentally configured your control key to be your alt key. Case in point: when I press alt+a, I get å. alt+v returns √, and alt+c gives us ç. Go into your settings and check again. They are located in System Preferences -> Keyboard -> Modifier Keys. Note: alt is also option.

Edit: I cannot duplicate this phenomena (see comments on this answer), so I will guess that the non-Apple keyboard is messing up the process somehow.

share|improve this answer
Thanks a lot. However no matter what I change, it will never become the command key again since I turn on the Keyboard Viewer and I saw that every time I assign a different key to command, it becomes option :(. Really don't know what to do now? Any suggestion? – Chan Jan 11 '12 at 6:54
@Chan That is odd. Let me play around with mine and see if I can duplicate what's going on. – please delete me Jan 11 '12 at 6:55
Many thanks for your help ;). I really appreciate that. – Chan Jan 11 '12 at 6:59
@Chan No problem! Couldn't reproduce, so I updated my answer. – please delete me Jan 11 '12 at 7:01
Thanks anyway. I guess I have to buy a Mac keyboard then. But it's totally weird since I set command to no action before. The only thing I did before that was reboot the computer from the command line since it was freeze. Other that, I couldn't think of any reason that would cause this problem. – Chan Jan 11 '12 at 7:07

If the option key is the one with the Windows logo on it, make sure you have the game switch (the switch with the little joystick on it) set to off. I think off is left.

With the game switch on, the Windows key is disabled (to prevent accidental Windows key presses from minimizing your game and sending you back to the Windows desktop).

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.