Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I noticed today that several of my recent contacts are not in my contacts. However, I have been texting them and their info shows up when I go to contact from a text message or recent call.

When I am in my address book and go to groups only All Contacts is an option, and that's where they are not. How do I get them all back into my contact list?

share|improve this question

8 Answers 8

Have you already tried to reboot your iPhone? (Push and hold the power button for 5 seconds, then slide to power off. Once your iPhone is shut down hold the power button for a few seconds to restart your iPhone) That might solve you issue.

If that doesn't solve your contact list issue go to 'settings' > 'Mail, Contacts, Calendar' > scroll down to 'Contacts' and play with the 'Sort Order', 'Display Order' and My Info' options. That might do the trick.

share|improve this answer

It looks like you're not the only one suffering from this issue (I know this topic is from 2010, but is describes perfectly your situation). I guess you've added those contacts to you list by using a 3th party app.
As of today, there isn't a fix for this issue, so I suggest you only add contacts by using the official contact app on your iPhone and add the ones not listed in your contact list manually.

share|improve this answer

I just went to 'Settings'> 'Mail, Contacts, Calendars'> scroll down to 'Contacts> select 'Import SIM Contacts'. All my contacts were restored to my Address Book.

share|improve this answer
    
Also did not work but thanks –  Chris James Champeau Dec 17 '12 at 19:37
    
This solution works great! When I clicked Import SIM Contacts, it came up with the options of importing to Hotmail or On My iPhone. When I selected On My iPhone nothing changed, but when I selected Hotmail (which is what I have selected to sync my contacts) it worked great! Thanks heaps! –  mezoid Jan 25 at 11:30

Go to Contacts, then click on Groups and make sure the "all iCloud" section is selected.

share|improve this answer
    
Yes that is checked –  Chris James Champeau Dec 17 '12 at 19:40

I made an an app which should help with this. Here's how to use it.

  1. download contact duster from iTunes Store which is free
  2. go to settings
  3. In settings go to contact duster and prefix your country code for eg +91 for India
  4. go to contact duster, it will prompt you to apply country code to all your contacts. Click on sure. Please backup ur contacts before this process.
  5. check your messages and call register as in recent calls. Your contacts names will be displayed.
share|improve this answer
    
Hi, Welcome to Ask Different. Can you please summarize the procedure for solving the issue in your answer? Thanks! –  Maverik Oct 15 '12 at 11:11
    
Hi, lucaghera, thanx for going through my answer, can you please let me know where exactly you are facing the problem. –  foneadvisor Oct 19 '12 at 8:25
1  
I'm not facing the problem. Explaining the solution in the answer, and not by means of a link, is a best-practice of Ask Different. You can use the links for providing additional information, but the answer should be self-explaining. –  Maverik Oct 19 '12 at 8:29
1  
Please edit this for grammar and summarize the link. It's OK to self-promote within a narrow set of guidelines. See the FAQ and flag this if you need assistance or would like it undeleted should you have an answer here rather than a link to your site. –  bmike Oct 19 '12 at 15:24

Had a similar problem after doing a restore on my iPhone 4. I just tried something that seemed to work. Went to contacts and selected groups. Selected Hide All Contacts and immediately selected Show All Contacts again. The missing contacts re-appeared along with duplicate entries for the one's I recreated.

share|improve this answer
    
Tried it not working, thanks though –  Chris James Champeau Dec 17 '12 at 19:37

Navigate to Settings > iCloud then turn Contacts off. It this was causing the problem you will notice that your contacts come back. Then go back to the same place (Settings > iCloud) then turn Contacts back on then select Merge.

share|improve this answer
up vote 0 down vote accepted

I actually figured it out playing with it today, the contact would not appear in my contacts but if I searched my phone they would appear, so if I couldn't find them within contacts...I would first search for the contact...open it...and then edit the contact, then they would show up...

Seemed strange but it works and new contacts are now being added as normal, must have been a glitch at one point as all the contacts that I cannot see were added in about a 2 month span.

share|improve this answer

protected by Community Feb 12 '13 at 11:54

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.