Sign up ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I have four disks in my Mac Pro. The boot disk and two others mount when OS X starts but the fourth one does not. I can mount it in Disk Utility and it appears to be all right.

How can I tell Mac OS X to mount it?

diskutil list /dev/disk2s2
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *1.0 TB     disk2
   1:                        EFI                         209.7 MB   disk2s1
   2:                  Apple_HFS Broken                  999.9 GB   disk2s2

Update: There seems to have been a misunderstanding about this question. I do not want to find out what's wrong' with my disk I named "Broken". It appears to work fine. I also reformatted it several times. I want to know how to tell OS X to mount a specific disk at boot. I named the disk "Broken" because it doesn't mount automatically, not because I have any problems with it as such and nor are there any error messages. Just forget I mentioned the disk and answer the question how to tell OS X which disks to mount at boot, if you know the answer. Thanks.

share|improve this question
You say you can mount it in Disk Utility as if you cannot mount it via the Finder sidebar? – gentmatt Jan 9 '12 at 18:40
How can I navigate to it when it isn't mounted? I think you are confusing mounting a drive with opening it in Finder. The drive is not mounted. This means it is not available to the system as a volume, only as a device (like "disk2s2" in the case of this drive). When Mac OS X boots it mounts all the drives, usually. – Andrew J. Brehm Jan 9 '12 at 20:21
Linux has an /etc/fstab, Mac OS X does not (at least my installation doesn't seem to have one). Here a "device" is really a lot of things, but some devices are really disks (or similar) and contain file systems. By mounting them, the file system becomes part of the system and can be accessed by the Finder and other programs. – Andrew J. Brehm Jan 9 '12 at 20:41
Non-journaled HFS+ hasn't been the default for many years. Journaling should be enabled on all your HFS+ volumes, unless you have a very good reason not to - I think some Linux/BSD HFS utilities don't like journaled HFS+. – Brett Dikeman Jan 10 '12 at 17:41
These answers mostly miss the point! He is not looking to mount at login. He wants to mount at boot time. This isn't exactly a difficult question but it seems to be a difficult answer. For example, you want an external disk (these are not auto mounted it seems while internal drives are) to be used for a network Time Machine Backup location. You don't want to limit network devices to being able to backup only when a certain user is logged into the computer. You want it to backup ALL THE TIME. So, the question isn't why or why not at login time but how do you mount an external drive at BOOT time – Michael Aug 16 at 21:29

5 Answers 5

OS X uses diskarbitrationd which discovers new storage devices and probes them for mountable filesystems. The Disk Arbitration framework handles notifying applications of disk mount/unmount events, and allows them to influence whether a volume is mounted or not.

Consult the man page for diskarbitrationd for very limited further information; for example, diskarbitrationd consults /etc/fstab to determine if the discovered filesystem should be mounted other than at the default location(/Volumes/) or with special options (or not mounted at all.)

Reasons for diskarbitrationd not mounting a filesystem or "volume" on a device may include:

  • Errors (corruption) in the partition table.
  • A mismatch between the partition type and the filesystem.
  • A damaged filesystem which fsck cannot repair.
  • Hardware failure.
  • Filesystem is listed in /etc/fstab with noauto.
  • An application has used the Disk Arbitration framework to prevent auto-mounting

According to your comments, all your journaled filesystems are mounting, and the filesystem which isn't mounting doesn't have journaling turned on. Journaling was introduced in 10.2 Server and 10.3 Client and by now is considered a vital, critical feature. It should be enabled unless you really know what you're doing; hence why you must hold down the option-key in Disk Utility to disable it in modern versions of OS X. Make sure the volume has journaling enabled:

  1. Select the volume in Disk Utility
  2. Choose File->Enable journaling (if it is greyed out, journaling is enabled.
  3. Verify by choosing File->Get info; you should see "Mac OS Extended (Journaled)" as the filesystem type.
share|improve this answer
diskutil list /dev/disk2s2 /dev/disk2 #: TYPE NAME SIZE IDENTIFIER 0: GUID_partition_scheme *1.0 TB disk2 1: EFI 209.7 MB disk2s1 2: Apple_HFS Broken 999.9 GB disk2s2 – Andrew J. Brehm Jan 10 '12 at 17:25
Note that "Broken" is the name of the volume. – Andrew J. Brehm Jan 10 '12 at 17:25
I think you are labouring under the assumption that there is something wrong with the mount process itself. There is not. Mounting the drive works. It just doesn't mount at boot. – Andrew J. Brehm Jan 10 '12 at 17:30
It's only happening to one drive, and it's not automounting. Unmount and unplug the drive, then reconnect it, and I bet it won't mount automatically. There's nothing special about boot-time mounting, really. Please post all the information I requested by updating your question, not by pasting it here - the formatting is broken. – Brett Dikeman Jan 10 '12 at 17:32
Sometimes there are questions with insufficient detail and the asker never comes back, so they're closed. However, in this case, Andrew seems to be actively responding, so I'm going to leave the question open. He seems invested enough to realize that omitting troubleshooting steps may result in not getting an answer. – Kyle Cronin Jan 10 '12 at 19:56
up vote 3 down vote accepted

The volume is mounted automatically again.

I never did find out how Mac OS X decides which volumes to mount and which not. But whatever it is, Mac OS decided to mount the volume again. Apparently the solution is to reboot until it works.

share|improve this answer
I have another disk now which didn't auto mount but mounted fine manually. – Andrew J. Brehm Apr 21 '12 at 14:27

Assuming there's no dramas with the volumes themselves, you can mount additional volumes at login by adding them as Login Items for your user account in the System Preferences.

share|improve this answer
That opens a new finder window every login. No matter if you check-mark 'hide'. Kind of annoying. – gentmatt Jan 10 '12 at 6:58
It's also impossible since Login Items are opened, not mounted. How would Finder even know which device to mount for an icon named "Hard Disk 2"? – Andrew J. Brehm Jan 10 '12 at 8:30
In my experience, it doesn't open Finder, it just mounts the Volume. I use this to mount shares from my Drobo (although I admit that I'm assuming that this works the same for local volumes). Will confirm the steps when I get home. – Tony Johnson Jan 10 '12 at 9:17
Volumes can be added to startup items by going to System Preferences > Users & Groups > Login Items. Select "+" to add a new item and select the Volume in question. Have confirmed that this works with Local Volumes as well as Network Shares. The result is the Volume mounted and an icon on the desktop. No finder windows are opened. – Tony Johnson Jan 10 '12 at 10:12
So this will really mount the volume, not just open (the already mounted) volume? – Andrew J. Brehm Jan 10 '12 at 12:17

In my case I had to mount an afp volume at boot, and I wanted it to be transparent. What I did was to create an script and added it to login items. That way the window is not shown.

tell application "Finder"
    mount volume "afp://ServerName._afpovertcp._tcp.local/VOLUMENAME" as user name "macUser"
end tell

you can try to do something similar with

do shell script "diskutil mount /dev/disk2s1"
share|improve this answer

Go to System Preferences>Accounts>Login Items. Click on the plus sign and add your drive on that list. Every time you log into your account, Finder will automatically mount that drive.

share|improve this answer
This is the same answer as Tony Johnson's. Read the comment there. – Andrew J. Brehm Jun 7 '13 at 7:29

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.