Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I live in East TN but when I change my time settings to automatic, it says I'm in Chicago. I have to manually set it to Atlanta so that I don't get the Central time zone.

Before, it used to use Houston. So all I my google business searches would default to Houston.

Is there any way I can convince this phone I live in Hixson, TN?

share|improve this question
I wrote a big response regarding wifi triangulation and access point location registration and what not, but I would think that iPhones' would get time zone data from cell towers/carriers, and everything else would do it's best otherwise to get location / else default to Cupertino and have you manually choose it. I'm not sure, so I'm not answering. – Jason Salaz Jan 5 '12 at 16:42

The iPhone (like pretty much all cell phones that support this feature) gets its timezone information from the carrier. Unfortunately many carriers send out the wrong timezone information and there's very little you can do about it other than switch off the Set Automatically option in the Date & Time settings.

share|improve this answer
You couldn't call the carrier? Surely this is a larger problem than just a customer-end one. – Jason Salaz Jan 5 '12 at 20:21
Have you ever dealt with AT&T? – cbmeeks Jan 7 '12 at 21:32

We went by car from Eastern time (Tallahassee FL) to Central time (St. Louis)), my iphone 4S changed at the time zone border, on the way back my wife's iphone 4S switched exactly at the timezone border, but mine, now a day later still shows Chicago time (both phones are on the newest OS),

Powering down (pressing home and side button) and up again remedied the problem (now back on New York time, why not Atlanta is a mystery to me).

share|improve this answer

On mime the workaround is to switch the event to all day then switch it back and it is correct,,

share|improve this answer
This does not provide an answer to the question. To critique or request clarification from an author, leave a comment below their post - you can always comment on your own posts, and once you have sufficient reputation you will be able to comment on any post. – Thecafremo Mar 22 '13 at 11:58
This does not really answer the question. If you have a different question, you can ask it by clicking Ask Question. You can also add a bounty to draw more attention to this question once you have enough reputation. – Graham Miln Mar 22 '13 at 12:47

Your carrier is using a proxy ...verify this by checking your ip address location on your phone. It will likely show you the area where all your internet activity is getting filtered through.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.