Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Why is it not possible to have iTerm2 or Terminal app take up the full available space on the screen. Let me show an example:

iTerm2

It's hard to see but if you look on the right and bottom edge, there is some extra space. It seems impossible to expand it to use that space. What is causing this?

I used apps that make the window take up the full screen size, such as Breeze. All other apps work fine, taking 100% of the screen space, except iTerm2 and Terminal.

Btw, I do know about native fullscreen but I would like to know why I can't make my terminal take up 100% of the space.

share|improve this question
    
By "take up 100% of the space" do you mean by simply manually maximizing it? In Lion, if I use the native fullscreen method for Terminal.app, it works as exactly as expected. –  cm2 Jan 5 '12 at 16:23

4 Answers 4

up vote 5 down vote accepted

Terminals have a fixed character width and height, and most (all?) terminal application programs make the window an even multiple of that size (then add the window title, some margin around the sides, etc.), so there will never be a partial row or column visible.

They could theoretically add more margin at the right/bottom of the window when the window is zoomed out, but then your question might merely be replaced with someone else asking “Why is there always some blank space at the window edge when the window is zoomed?”.

And what should happen to the window if you resize or show/hide the Dock (for example) such that the window is no longer the same dimensions as it would be if you zoomed it again to fit the new display area? When you Zoom a window, it isn’t placed into a “zoomed” state, it’s just resized to the current available display area at the time you Zoom it. If the available display area changes and you haven’t asked it to Zoom again, then what?

Not that these aren’t solvable, but there are a number of dynamic behaviors to consider, and terminal applications typically keep things simple.

Note that Mac OS X Lion “Full Screen” is an actual state that the window is in and Terminal always fits the window to the size of the display, updating when the display size changes, and adds margins as mentioned above. The size of the Dock, for example, is ignored.

share|improve this answer
2  
You can easily 'verify' this behavior by manually resizing the terminal window. You'll notice that it 'stutters' because it resizes only by a fixed character width. –  gentmatt Jan 5 '12 at 7:09

Hold down control and you can resize it to take the whole screen (although it won't necessarily add another row or column of text).

share|improve this answer
1  
What OS version? I can’t get that to work. –  Chris Page Jan 11 '12 at 2:39

This works for me (on Mountain Lion).

Go to: Preferences -> Profiles -> Window.

Set:

Columns = 204

Rows = 54

Style: Left of Screen

Screen: Main Screen
share|improve this answer

Here's a workaround I've been using for Terminal (should work with iTerm2 too).

Use the standard Window > Zoom option followed by the Fullscreen option of Spectacle (++F).

Window > Zoom leaves the terminal window in the original state (as seen in your question, with the thin space on the right). Full Screen option of Spectacle just moves the terminal window by half a character (I guess) to the left and fills the gap on the right.

OS: Mavericks, 10.9.1

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.