Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Mac Mail is changing my "reply to" email address on my emails. I have several accounts set up in Mail, and when I send an email from one account, and people reply to that email, it sends the email to a different account of mine than the one I had sent the email from.

  • There is nowhere that I can find in the Preferences to set a "reply to" address.
  • Apple's support documents indicate that the "reply to" address would be the address your email was sent from (makes sense) unless you type a different address in the "Reply To" field.
  • Even when I typed the address I was sending from into the "Reply To" field, the receiver of the email STILL had the different email show up when they hit reply.

I also tried this in the Terminal, found on an about.com site: "defaults read com.apple.mail UserHeaders"

The response was "The domain/default pair of (/Users/Library/Preferences/com.apple.mail.plist, UserHeaders) does not exist" which should mean that there isn't some overriding "Reply To" address set.

Any help would be GREATLY appreciated. Thanks so much all! Happy 2012!

share|improve this question
1  
Have you checked if the Mail is sent from the right account? In a mail composition window, there should be a drop down box, which lets you choose the mail account to use. You can also set the default mail account to use in Mail.app's preferences. –  Arne Jan 4 '12 at 15:59
    
Thanks for your reply. Yes, I am using the email I want in the drop down box of the composition window. I also have set in Preferences -> Composing -> Send new messages from: the email address I want. It is just the "reply to" that is somehow getting changed. =/ –  ObjectiveFlash Jan 4 '12 at 17:00
    
In the accounts preference window, try dragging the account you want on the top of the drop down list to the top of the listed accounts there. I would assume that what you did (" Preferences -> Composing -> Send new messages from: the email address I want") would do it but if memory serves dragging accounts was an earlier way to do this or do something like it. –  Richard Jan 5 '12 at 12:16
    
Thanks Richard. The one I want to be the main "reply to" account was already on top. I dragged it down and then dragged it back to the top, but as expected it did not fix the issue. =/ –  ObjectiveFlash Jan 8 '12 at 6:26
    
The account preferences window affects the sent from mail headers and the SMTP server and not reply to –  Mark Oct 17 '12 at 17:59
show 1 more comment

1 Answer 1

up vote 0 down vote accepted

Wow! It was somewhat obvious... in Preferences -> Accounts there is a setting for "Outgoing Mail Server" and that is where I needed to make some changes. Thanks everyone that tried to help!

share|improve this answer
1  
However that should not affect reply-to header which you set i9n the compose window for mail –  Mark Oct 17 '12 at 17:58
add comment

protected by Community Nov 19 '12 at 16:01

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.