Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I have a custom keyboard layout which MacOSX doesn't recognize as Latin, so it doesn't allow me to remove the US default layout.
I'd like to know what would make my layout be recognized as Latin.
Is the US default layout stored in a file somewhere? so I can compare it to mine and figure out what to change.
My layout is a modified US-international so it should be recognized as Latin with no problems.

Update: I solved it by setting the keyboard id to 1.

enter image description here

share|improve this question

4 Answers 4

Disclaimer first: I haven't tried this myself.

In the message from user biovizier at 05-07-2007 10:44 PM in the MacWorld forum thread: http://hintsforums.macworld.com/archive/index.php/t-71629.html , it is claimed that it is possible if it matched both the ID and the name of an existing "approved" layout, and that the cache should be cleared to remove the old, compiled version of a such.

However, the thread is quite old so it may have been tightened even further in newer versions.

share|improve this answer

I think to do what you want you would probably have to modify what is in AppleKeyboardLayouts.bundle, and I haven't seen a way to do that.

share|improve this answer

There are several different layouts you can use and install from The University of Chicago Library page:

Handy Unicode utilities tools listed here:

And, you can also customize your layout System Preferences > Language & Text > Text:

enter image description here

share|improve this answer
    
Thanks, but it's not what I asked. –  Petruza May 4 '12 at 2:31
up vote 0 down vote accepted

I solved this by setting the keyboard id to 1.

enter image description here

share|improve this answer
1  
Thanks, very useful! –  Tom Gewecke Apr 29 '12 at 23:23
    
I changed the id, touched /Library/Keyboard Layouts/, and restarted, but still can't disable the U.S layout. I've set my custom layout as the default by running sudo "/System/Library/CoreServices/Setup Assistant.app/Contents/MacOS/Setup Assistant". I tried enabling other input methods as well... Do you have a physical keyboard with a Chinese layout or something? –  ؘؘؘ Apr 30 '12 at 12:59
    
@Lri Setting the id to 1 also did not work for me, I tried User/Library, Library, and System/Library. –  Tom Gewecke Apr 30 '12 at 19:34
    
@Lri @Tom Sorry to hear it didn't work for you. I just set the id to 1 and worked, when I selected the U.S. keyboard, it wasn't greyed out anymore, so I took it out. I just used ~/Library. It doesn't work perfectly, as the keyboard turns to chinese whenever I have to enter the admin password, and I cannot change it. (it's ok, since I just type it and hit enter instead of space and it outputs in Roman letters). I just have a plain physical U.S. keyboard. –  Petruza May 2 '12 at 13:19

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.