Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

A recent mail file corruption has led me to finally putting Eudora to bed. Since my personal email has been backed by gmail for a few years, and my work email is a Google apps email account, I figured I'd take advantage of server-based storage to not worry about fixing Eudora mail files, but just use IMAP to sync up with the servers in Apple mail and be done with it.

Well, my personal account and my company account are both the same user name, i.e. username123@gmail.com, and username123@company.com. (Not real.) And it seems like this is causing a collision in Mail.app. On editing the initial mail config setup, I get an error: "Invalid Directory: The account path /Users/.../Library/Mail/IMAP-username123@imap.gmail.com is already being used by the account Company Mail".

I was concerned by this, but it did seem to be busily downloading mail into the "All Mail" folder for the new account, so I let it run. But, yeah, it seems broken. What should be individual inbox folders for each account show all the same sets of messages. That's no good.

A funny thing is that I've had these same two accounts on my iPhone, with IMAP, and it keeps them straight!

So, am I doomed to not being able to use Apple Mail in this scenario?

Update: Today, the two inboxes look separate, after a restart of Mail overnight. However, I still get the same error when I try to change the personal account to send through an alternate server, so I think there is still a problem here.

share|improve this question
    
I don't think both your user accounts being user123@domain.com is your problem. I'm in the exact same scenario (both work and personal email accounts are IMAP, and both are the same username @ their respective domains), and it works great. That error message you quoted makes me wonder if you accidentally entered the wrong address for your work email. –  Warren Pena Oct 29 '10 at 6:18
    
@Warren: I think the trick is that both my accounts are backed by Gmail in the end, so the incoming mail server for each is imap.gmail.com. Is that the same situation for you? If so, let me know and I'll work out a way to send you screenshots so you can tell me what I'm doing wrong. –  khedron Oct 29 '10 at 15:18
    
Ah, good point. No, only my personal account is backed by Google. –  Warren Pena Oct 31 '10 at 4:49
    
@Warren Alas! I was hoping you'd found the secret to what I was doing wrong. Thank you for trying, through. –  khedron Nov 1 '10 at 20:09

3 Answers 3

up vote 4 down vote accepted
+50

Follow these steps:

  1. Open Mail and delete each of the conflicting accounts. Close Mail.
  2. Go to ~/Library/Mail/ and make sure any IMAP-username123@imap.gmail.com folder has been deleted. If there is any such folder left, delete it now.
  3. Open Mail and create one of the accounts and let Mail load your messages. Close Mail.
  4. Go to ~/Library/Mail/ and verify that a folder called IMAP-username123@imap.gmail.com has been created.
  5. Open ~/Library/Preferences/com.apple.mail.plist. If you have installed Xcode, this file will open with Property List Editor. Otherwise you can download a free trial of PlistEdit Pro to open this file. Using a plain text editor with .plist files is more difficult.
  6. With the .plist file open, click the disclosure triangle for MailAccounts. Here you will find Item 0, Item 1, etc.
  7. If you click the disclosure triangle for each of the Item headings, you will find that one of them has the value username123@gmail.com or username123@company.com for the AccountName key, depending on which account you created in step 3.
  8. Change the value for AccountPath for this Item so that the path will not collide with that of the next account you are to create.
  9. Save and close the .plist file.
  10. Open Mail and let it reload your messages. Close Mail.
  11. Go to ~/Library/Mail/ and verify that a folder with the path value you provided in step 8 has been created. Delete the old folder called IMAP-username123@imap.gmail.com.
  12. Open Mail and create the remaining account normally and let Mail load your messages.
share|improve this answer
    
This sounds very promising. I was experimenting with my DNS powers to create an imap.company.com as a CNAME for imap.gmail.com. I don't like the certificate warnings I was getting, though. So I may try this, we will see ... –  khedron Nov 1 '10 at 22:30
    
This has worked, thank you so much! I'm directing Ars Technica & Apple Support forums here. FWIW, it does look like I might have been able to avoid this if initially in the company account creation, I'd (correctly) entered in username123@company.com for the name, instead of just username123 -- I had to make that change eventually for it to work in the first place, but I think maybe the AccountPath setting was set initially by the username value and not updated. On this second go around, where I knew better what I was doing, the AccountPath contained @companyname.com. –  khedron Nov 3 '10 at 0:03

You could try setting one up as POP but leave the messages on the server, and the other as IMAP.

share|improve this answer
    
I have read (on Apple's support forum or MacOSXHints or somewhere else) that this will work. But, that's pretty poor! I'm hoping to hear that someone else has managed it some other way. –  khedron Oct 29 '10 at 1:12

I have seven Gmail accounts set up on Apple Mail via IMAP, running OS X Mountain Lion. I had no problems setting up any of them except one. Long story short, the fix was easy. I turned off the 2-step security verification in the Google account settings. That was it!

share|improve this answer
2  
Welcome to the site! While this appears to answer the question based on the question title, the question body highlights that the specific problem seems to be multiple accounts with identical user names at different domains. (I'm editing the title of the question to make this clearer.) –  Jaydles Nov 15 '12 at 21:40

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.