Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I tried to reload Cydia, which stopped working on my jailbroken iPhone 4. I downloaded "Redsnow" and "Ipsw 4.3.2", which worked, until I went to use and downloaded an app with Cydia.

I did not realize that this jailbreak version needed to be tethered to reboot! So i put my iPhone back in sleep mode and boot from Redsnow only to have it get locked in the logo boot mode for 2 days now! Yesterday I panicked and downloaded the latest update from iTunes and did a factory instal with no avail - still in this boot logo loop

How can I fix this and use my phone?

share|improve this question

You need to first put your phone into DFU Mode. Then, run Redsnow, go to "Extras" and select "Just Boot".

share|improve this answer

My suggest would be to restore your iPhone using iTunes and re-jailbreak it using the latest Absinthe which supports jailbreaking the most recent iOS 5.1.1.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.