Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Sorry I'm being vague because I don't even know where the problem can be.

Yesterday I was using the internet just fine. Today on the same wifi router and on another 3G connection, I couldn't access any webpages. I tried using those exact same two connections with another laptop and it worked.

I cleared the cache, set up my DNS server to be OpenDNS ones, made sure there was no proxy activated, but no luck. Tested with Safari, Chrome, and Firefox.

Ping doesn't work. Host does.

I am no networking expert. I'd like help with solving this issue.

Thank you.

Mac OS X 10.6.8 / Firefox & Chrome : Latest

share|improve this question

1 Answer 1

Ok. I fixed it.

A bit of more details first.

dig / nslookup / host commands were working. So I actually had access to internet.

The problem was ping and all Browser using the System resolver that was not working.

I unload then reloaded the /System/Library/LaunchDaemons/com.apple.mDNSResponder.plist with the -w option. And it worked.

Hope it can help,

share|improve this answer
    
Can you please be a bit more specific as to how you solved this problem as I seem to be having a similar one. Thanks –  D.Shah Jul 21 '13 at 12:18

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.