Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I'm using a MBP with a second (external) monitor and since I upgraded from Snow Leopard to Lion, I encountered some display issues that appear in the Application Switcher, and sometimes in the menu-bar.

In case of the menu, the font in the dropdown appears with jagged edges, as if there suddenly was a huge contrast-change affecting only the menu-items.

In case of the Application Switcher, the effect is even worse as shown in this image:

display issue on mac os x lion

Interestingly, this glitch seems to only affect overlays like the Application Switch or the menu. The rest of my OS and all Applications are looking fine.

If I go to System Preferences and choose another color-profile for my monitor, the issue is gone. If I select the previously selected color-profile, the issue appears again. The issue happens with every profile though. So if I choose Adobe RGB (1998) and restart my computer, the issue occurs. It disappears when I select another profile, for example Apple RGB. After a restart, the glitch will re-appear (even with the newly selected Apple RGB) and only a profile-change will remove it.

It's not too big of a deal, but if anybody has some pointers how to resolve this, I'd really appreciate it. Btw. the issue appears on different monitors, so it's not some monitor-hardware fault or anything.

Update: I was under the impression that the issue reappears after a restart. That assumption was wrong, the issue appears whenever I switch the external monitor (eg. change from monitor at work to the one at home).

share|improve this question
    
I had the same problem but it seems to be working fine now after upgrading to 10.7.3. –  revolver Apr 11 '12 at 2:23
add comment

4 Answers

up vote 3 down vote accepted

I've had an identical problem on my 2010 MBP since upgrading to Lion last fall. Here's what I did today that seemed to fix the problem:

1) Go into Macintosh HD and find /Library/colorsync/profiles/displays
2) Move all files in the 'displays' directory into a backup folder on your Desktop
3) Open System Preferences > Displays and click on "Color" for each of your displays
4) Your computer will take a few seconds and create a fresh display file for each monitor.

After doing this all the weird screen artifacts and colors have gone away on both my MPB LCD display and my 19" external monitor connected with mini-DVI.

share|improve this answer
    
Interesting. I'm currently checking this.. will see if it works when I'm back at home. Although going to Displays > Color didn't create new color profiles. It was disconnecting/connecting the external Monitor that did this (you might want to add/fix that in your anser). –  bummzack Apr 11 '12 at 8:12
    
This seems to have solved the issue. Thanks. –  bummzack Apr 12 '12 at 8:31
add comment

I am also experiencing the same problems and have posted a thread to the Macbook Pro Apple Forums. While there isn't any answer yet you might be interested in following along that thread.

So far the only reliable way to fix it would be to restart the machine. Or to log out and log back in. Neither method is satisfactory.

share|improve this answer
1  
That seems to be the same issue as here. I didn't notice that it's caused by screen-switching! That might be the root of the problem, as I was doing that as well. Will watch that thread.. please make sure to post the solution here if one comes up! –  bummzack Dec 30 '11 at 23:25
add comment

I have been able to work around the issue using the free app gfxCardStatus to switch between integrated and discrete graphics on my MBP.

It doesn't matter which you use, switching to the other one fixes the problem until next time.

share|improve this answer
    
Thanks for this, I'd set it to integrated only to preserve battery. When I connected to a monitor later, it wasn't recognized. I had to change it back to dynamic. –  jman Jul 20 '12 at 20:05
add comment

Here's a sequence I have had some luck with without having to log off and on.

  1. MBP in standby mode.
  2. Ensure monitor is turned off.
  3. Hook up external monitor cable.
  4. Open MBP and wait for recognition of second monitor.
  5. Power on the second monitor and sign in.

This works with both my Dell and Lenovo monitors. Both of them are my primary displays.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.