Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

My iPhone 4 has trouble connnecting to a Sony speaker dock, it will continuously charge.

Sometimes it will play music through the speakers; sometimes it will not.

If it is not playing music it acts exactly as it would if it were to play music (the play/skip area drops down over the volume) but nothing comes through the speakers.

If it DOES play music at all it often seems to come disconnected from the dock every 30 seconds or so only to reconnect itself and have to be pressed play again.

I believe that is just a problem with my iPhone 4's connecting area... any suggestions at all would be so helpful!

share|improve this question
    
Sounds like the dock isn't working. You should try using another dock. –  Graeme Hutchison Dec 27 '11 at 9:09
    
Tried another dock, same problem. Now it is even worse. Just charges but no other response. Tried a friend's iPhone 4 worked perfectly. –  Blayne Dec 29 '11 at 8:31
    
Take it to the apples store. –  Graeme Hutchison Dec 29 '11 at 8:49
add comment

1 Answer 1

Have you tried looking inside your iPhone side of the connector? I've noticed that a lot of pocket lint tends to build up in there over time and I just took a toothpick and dug all of it out. My wife's iPhone wasn't syncing when connected to my laptop and this turned out to be the issue.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.