Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I have a MacBook Pro (2.4 GHz Core 2 Duo, running OS X 10.6.8) that does not reconnect to its stored WiFi network after it restarts or goes to sleep. To reconnect, I need to go into System Preferences and choose a network in Airport settings. Then it happily reconnects and stays connected.

I saw this question, and tried to delete and re-add my preferred network (I only have one). I went into Advanced, deleted the network, turned Airport off and on, and chose my network from the dropdown. It knew the password already though.

I was going to delete/move the preferences file containing network/WiFi settings, but I can't find it. Would this be helpful? If so, where is that file stored? I've already looked through ~/Library/Preferences and /Library/Preferences to no avail.

share|improve this question
    
What kind of router are you using? –  lrussell810 Dec 24 '11 at 6:37
    
BTW, it's no surprise that the password was already known. It's stored in the keychain. If you delete the network, the password remains in the keychain. –  gentmatt Dec 24 '11 at 7:38
    
This worked for me. –  Dan Aug 12 '12 at 20:31

5 Answers 5

up vote 2 down vote accepted

The problem got partially better on its own, and it's not clear why. There were also a lot of old networks in the list of previous wifi networks in System Preferences, and it helped to delete them.

The complete fix, however, ended up being to go into the list of wireless networks (in System Preferences > Networks > Airport, Advanced) and move the desired network up to the top of the list so it was joined first. There was one called "linksys" on top that was matching a neighbor's network, and then failing to get internet access for some reason; I think it was added a long time ago for a different network of the same name.

I thought I had tried this before, but either something changed or I didn't actually try it. I'm asking this question to help me troubleshoot someone else's computer, so I'm not aware of everything that might have changed since I originally posted the question.

share|improve this answer

There is one famous cause of this problem - interference between bluetooth and wifi, which plagues metal Mac laptops.

To test if this is the source of your problems, turn off your Bluetooth via System Preferences / Bluetooth and see if the issue goes away.

If this is indeed the problem, the only cure (as far as I know) is to stop using Bluetooth entirely, or switch the frequency of your wireless setup to 5GHz.

share|improve this answer
    
Tried turning off Bluetooth and it didn't work. –  Mr. Jefferson Dec 29 '11 at 3:49
    
Interesting. Then yours is a separate problem. I wonder if it might have something to do with your router. –  dan8394 Dec 30 '11 at 11:05

The preferences files you probably want to look at are:

  • /Library/Preferences/SystemConfiguration/com.apple.network.identification.plist
  • /Library/Preferences/SystemConfiguration/com.apple.airport.preferences.plist
  • ~/Library/Preferences/com.apple.eap.profiles.plist

As @gentmatt said, you could also try deleting the network password from your Keychain (use Keychain Access.app).

share|improve this answer

This is also a very common side effect of the WiFi network password changing but using the same SSID.

The old password gets stored in the Keychain, and does not get overwritten. Or two entries for the same SSID are in Keychain.

Once you go into Keychain Access.app, look for 'airport network password'.

If it is your WiFi network to control and nothing else works, try a new unique SSID and password.

share|improve this answer

Does this happen to all networks or just the one you're talking about?

If the latter, is your box a Netgear OEM (given out free by networks?) I have one in my house from Virgin Media which rejects my 2010 pro (same spec as yours) from automatically joining, and the way I solved it was asking them for a wireless access point box (very cheap, even if you have to buy it) and wiring that into my network. It joined immediately, and had no problems.

I also considered the possibility that there might be interference on the same channel as our network - we're in a very high-density area, so that might be causing the problem.

share|improve this answer
    
This is happening in an apartment building in a city, so it's possible that there's interference. But the router is a Linksys (actually, I think they're Cisco now...). –  Mr. Jefferson Feb 1 '12 at 3:09

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.