Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I'm trying to save a new event on iPhone calendar, but it just keeps giving me this error:

Cannot Save Event — That event does not belong to that event store

What can I do to fix this?

enter image description here

I'm using Google Calendar by default, but I get the same error even if I try to use another calendar, so I presume the fault is not in Google's servers. Never encountered this problem before – just started seeing it today. (Using iPhone 4 and iOS 5.0.1.)

share|improve this question
add comment

4 Answers 4

up vote 2 down vote accepted

Try these:

  • Close the Calendar app completely, then retry (this worked for me)
  • Reboot iPhone
  • Try editing the default calendar setting (Settings -> Mail, Contacts, Calendars -> Calendars)

If none of those helps, you could read through this apple.com thread for more tips.

share|improve this answer
    
Thanks for sharing the answer.. –  Dilip Rajkumar Jun 11 '12 at 11:23
1  
I followed all these instructions and my issue was resolved. –  David Silva Smith Oct 2 '12 at 11:26
add comment

If your phone is jailbroken (and your calendar is backed up) this can be fixed fairly easily.

  1. Turn off all calendars
  2. Delete the contents of "/var/mobile/Library/Calendar" (you can use something like i-FunBox or iPhoneBrowser - both free).
  3. Reboot the phone
  4. Turn the calendars back on again

Fixed the issue for me right away.

share|improve this answer
1  
I'd say anyone should try these steps first (whether the phone is jailbroken or not), because it's quick & certainly won't break anything. –  Jonik Jan 16 '12 at 10:45
add comment

In my case the problem was that the cursor (or maybe "highlighter" is better - hard to see!) was still on another event that I had just modified. I tried to use the "+" to add a second event to that day's calendar. When I input a second event with different times, then pressed "Done" I got the message "That event does not belong to that event store." I think the meaning of the error message is now clear - the second event couldn't be superimposed on the first. So in my case simply touching a different time slot on the calendar, then entering the new appointment, solved the problem.

share|improve this answer
add comment
  1. make sure to disconnect your phone from computer
  2. delete calcube
  3. close all apps
  4. reboot iphone
  5. reinstall calcube but do not select "calendar" yet. just select "US Holiday" for now.
  6. go through the setup
  7. open calcube, go to "Settings", select "calendar" now
  8. try adding in event in calendar in calcube
  9. you may need to reboot again

I did these about 100 times, then it finally work. hahaha.....

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.