Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I have two Macs sitting on my desk: a MacBook Pro (work computer) and an iMac (personal). I sync my iPad 2 with the iMac where all of my media and other stuff lives. Since the advent of iOS 5 and OTA syncing, however, the iPad has taken to syncing with both Macs, choosing (seemingly) randomly between the two when powered on and plugged in within WiFi range. The trouble is, when it syncs with the MBP, it generates dozens of "error while syncing" dialogs (which take awhile to individually dismiss) on the iPad because (I'm assuming) none of my content, apps, etc. are on that machine.

Is there a way I can stop the MacBook Pro from syncing with the iPad?

Thanks!

share|improve this question
add comment

1 Answer

up vote 2 down vote accepted

In iTunes on your MacBook Pro go to Preferences, then Devices, and then select the checkbox that says "Prevent iPods, iPhones, and iPads from syncing automatically"; that should solve your problem.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.