Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

How can I disable iMessage for a phone number if the iPhone it's attached to has been destroyed? My sister dropped her iPhone in the bath, so she is now using an older non-Apple phone. Whenever I send her a message, it gets sent as an iMessage (and even says "Delivered"), but her device never receives the message.

The only information I could find was this Apple knowledge base article which states the following:

If you plan on transferring your SIM card or phone number from an iPhone to a device that does not support iMessage, turn off iMessage in Settings > Messages first. If you do not, other iOS devices may continue to try to send a message using iMessage first, instead only using SMS or MMS.

However, since this iPhone was destroyed, we can't get into the settings to unregister her phone number.

share|improve this question
    
Does any of the information here help you? apple.stackexchange.com/questions/27274/… –  KatieK Mar 21 '12 at 22:07
    

12 Answers 12

Find your sister in the Contacts in your iPhone. Change her current mobile number from "iPhone" to "Mobile". Let me know if this works!

share|improve this answer
    
Her number is already listed as "mobile". –  Stephen Jennings Dec 20 '11 at 8:54
4  
This is just a tag, I can put anything I want there, Apple doesn't use this for iMessage. –  Loïc Wolff Dec 20 '11 at 10:44

Try to log in to your iPhone with her Apple ID and turn off the settings for iMessage there. Worst case you need to insert her SIM card into your phone and do the changes.

share|improve this answer
1  
I don't think it is SIM related. iMessage is via your Apple account, not your phone number. –  Jim McKeeth Dec 1 '12 at 4:03
    
@jim without the Sim I cannot find any way to remove my number from iMessage after a few hours of trying a bunch of things, including the information in this topic. So I think it indeed is SIM related. –  Jeff Atwood Dec 3 '13 at 2:57

Go to https://supportprofile.apple.com/MySupportProfile.do, log in with her Apple ID, click on Edit products and click on the "x" to the right of the iPhone. Click Unregister.

share|improve this answer
    
Does this actually cancel notification center messages without having control of the device? That would be cool, but I haven't seen this reported as a way to disable delivery of messages - just to remove it from your list of devices for easy self service when contacting AppleCare. –  bmike Dec 29 '12 at 17:21
    
I have devices using iMessage that are not present in this list, so my guess is it won't have an effect on iMessage. –  NReilingh Dec 3 '13 at 6:36

In time, that device will expire as a destination for messages but since the phone was physically destroyed by dropping in water, it's highly likely the "delivered" message is due to another Mac or iOS device being registered for iMessage as opposed to the server thinking it had sent a message to a working iPhone (when that iPhone no longer works).

share|improve this answer
  • Use a friends iPhone, go into Settings > iTunes and App Store
  • Sign out of their Apple ID and then sign into your Apple ID
  • Then go turn iMessage off under Settings > Messages
  • Sign out the same way and sign back into your friend's Apple ID
  • Turn iMessage back on in Settings and try to message yourself on their phone

This will fix the problem immediately.

share|improve this answer
    
this does not work -- the number is dimmed out in the Settings > Messages and I cannot deselect it. –  Jeff Atwood Dec 3 '13 at 2:56
    
iMessage uses a separate account from iTunes. My wife and I share iTunes accounts but have unique iMessage accounts. Your answer makes no sense. –  andleer Dec 3 '13 at 3:19
  • First get an iPhone that is iMessage compatible.
  • You will have to do a master reset (which erases everything) on this phone after, so make sure that this iPhone doesn't belong to somebody who cares about all of their stuff.
  • Then, take the existing SIM card out of the iPhone and sign in to your sister's iMessage account.
  • It is important that you do this with FaceTime so that the iPhone doesn't associate your sister's number with the account on that iPhone.
  • Put your sister's SIM card in the phone.
  • Turn iMessage and FaceTime off.
  • Take the SIM card out of the iPhone, and then go to Settings > General, scroll down to Reset. Tap Reset, and then tap Erase All Content and Settings. This should solve your problem right away.
share|improve this answer

A bit of a lark here but I read on the Apple forums that resetting your Apple ID password will immediately cause the association between your old phone number and any iMessage account to timeout. (Sorry can't find the link...)

The non-lark part here is that I do know that this association does eventually timeout. I had two iPhones a few weeks ago each with their own working SIM and phone number. One of the phones got wiped and the SIM tossed. While the old phone number and associated iMessage address stayed around for a few days, it eventually disappeared.

https://appleid.apple.com/cgi-bin/WebObjects/MyAppleId.woa/

share|improve this answer

The only thing that worked for me was changing my AppleID to use a different email address. That resets something on their end, and the next day I started to get text messages again from people who were previously sending iMessages.

share|improve this answer

I ran into this same issue, not with a broken iPhone though. I have a Nexus 5 to replace my old iPhone 4. My wife's texts to me from her iPhone kept going as iMessages.

I found this article that helped me solve the problem.

Note: If you no longer have access to the iPhone that is using the number you want to remove, reset your Apple ID password.

http://support.apple.com/kb/HT5538

What I did was disable facetime and iMessage on my phone (with no sim). Changed my apple ID password. After this texts worked again to me.

share|improve this answer

The good and sure way of doing it is this:

Go to your cellphone provider, for example, AT&T. Have them do a "SIM Replacement" on your new phone. You will have to provide your phone number and ID. They will switch the SIM card number linked to your account. Depending on the generosity of the store you go to, this will cost you 0-5$

share|improve this answer

Changing your apple account password will fix this problem. I just did it and it worked. Thanks!

share|improve this answer

The simplest solution is to contact Apple Support (as this article makes clear) since they actually have engineers that can modify which devices and phone numbers are associated with your (or another's Apple ID).

So, just contact Apple Support.

share|improve this answer
2  
This is a very handy development. In the past, Apple wouldn't assist in clearing up registrations for iMessage, but getting assistance from the vendor is better than my answer of just waiting for the registration to expire (which I believe was all you could really do in December 2012). –  bmike May 14 at 14:18

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.