Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My iPhone (3gs) has this behavior:

  • I'm typing a text and I put a certain letter in caps
  • I might decide the letter shouldn't be in caps so I press backspace (a couple of times if I've typed a lot after the capped letter).
  • when I do this, my iPhone remembers the letter was in caps and already puts on caps (the upward arrow is glowing).

I don't want this (the last bullet). how can I disable it? I've checked the preferences and disabled settings -> general -> keyboard -> Auto-Capitalization and settings -> general -> keyboard -> Enable Caps Lock, yet to no avail.

share|improve this question
up vote 2 down vote accepted

It happens because you hit caps before typing a letter, so what the iPhone is doing is rather deleting all the code associated with that letter, it deletes the letter leaving the code, so if you backspace again it removes all the code from that space and moves back another space.

If you backspace one step further it removes this formatting.

The settings you have changed do not relate to your issue.

The first is to capitalize proper nouns that grammatically require a capital (which I wish would happen on all applications) the second is to enable the locking of the caps key, which means if you tap it twice in quick succession it will lock in uppercase.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.