Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Some months ago, I switched to the Colemak keyboard layout, which is mostly great. But, there is one annoyance that is imposed by OS X.

When the OS pops up a confirmation dialog to ask me to type my password in order to authorize an app for higher privileges, the OS switches my keyboard layout back to QWERTY whenever the password field of this dialog is focused. Not only that, but the OS prevents me from changing the layout back as long as that field has focus.

Now, I am perfectly able to type my password on the Colemak keyboard. In fact, I'm much better at it now than I am at typing it on QWERTY. I want this behavior to stop. Unfortunately, I can find no setting for this, neither in system preferences nor in a defaults read dump. But just because I can't find it doesn't mean it doesn't exist. Does anyone know how to fix this?

I'm running OS X 10.7.2 on a MacBookPro 3,1.

share|improve this question
add comment

1 Answer 1

up vote 6 down vote accepted

Put the .keylayout in /Library/Keyboard Layouts/ instead of ~/Library/Keyboard Layouts/.

share|improve this answer
    
Naturally, I never would have thought to try that. Thanks! –  Ryan Ballantyne Dec 18 '11 at 2:02
    
Sounds like this information should be included on the Colemak for Mac wiki page. –  Dave DeLong Dec 18 '11 at 3:25
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.