Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Ever since my company updated to Lion, terminal.app has been behaving differently. When I click on the dock icon, it sometimes opens several terminal windows at once, instead of a single one, and all of them display my previous session's activity, rather than just opening to a shell prompt.

What can I do to make the terminal go back to behaving the way it used to? I can't find anything in the prefs that would account for these changes.

share|improve this question
add comment

2 Answers 2

up vote 2 down vote accepted

If you prefer a graphical interface you can use the app TinkerTool.

This application gives you access to additional preference settings and allows to activate hidden features in the operating system.

enter image description here

share|improve this answer
    
Thanks! This is great. Generally I prefer command line when I'm on a linux machine, but I'm not as familiar with the actual program names on the Mac so the GUI is really helpful to make sure I'm affecting the correct apps. –  EmmyS Dec 20 '11 at 17:47
    
@EmmyS You should accept the answers when they solved your problem :) That way, when searching this site with the search bar, one can see that this has been solved. –  gentmatt Dec 20 '11 at 20:21
    
Sorry, I thought I had already accepted your previous answer. –  EmmyS Dec 20 '11 at 22:51
add comment

This is the resume feature of OS X Lion.

Undo resume for a specific application

Type the following command in the Terminal. Then restart the specific application.

In general the syntax is:

defaults write com."producer"."program-name" ApplePersistenceIgnoreState YES

Thus, in your case (Terminal.app) it is:

defaults write com.apple.terminal ApplePersistenceIgnoreState YES

If you want to set the resume feature again, simply write NO using the same syntax.

Undo resume for all applications

In order to disable this for all applications do this:

go to System Preferences->General enter image description here

share|improve this answer
    
Is there any way (even if I need to do it via terminal command) to set this on a case-by-case basis? There are some apps where I want this behavior, but for most of them I don't. –  EmmyS Dec 16 '11 at 21:40
    
Yes, I've updated the solution above. –  gentmatt Dec 16 '11 at 22:41
    
I have unchecked the "Restore windows when quitting and re-opening apps" option but TextEdit still re-opens files I have abandoned the last time I used it. Any ideas? –  Andrew J. Brehm May 29 '12 at 15:45
    
@AndrewJ.Brehm No idea why this is happening. How long has this been going on? I just disabled this feature as well, and I had to restart the tested applications several times to see the change take affect. –  gentmatt May 29 '12 at 15:56
    
I disabled the feature when I saw it. I didn't even want to know what new terror Apple had tried to bring upon me. However, TextEdit has always re-opened files that I never saved. –  Andrew J. Brehm May 29 '12 at 16:51
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.