Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I recently upgraded OS X from 10.6 to 10.7. Since doing this, certain command line tools I installed via MacPorts, such as ImageMagick, stopped working. For example when I run $ convert Jobs.png -resample 72 Jobs.png I get:

dyld: Library not loaded: /System/Library/Frameworks/OpenCL.framework/Versions/A/Libraries/libclparser.dylib
Referenced from: /opt/local/bin/convert
Reason: image not found

How can I fix this?

What I've tried:

I've tried the following commands, to no avail:

$ sudo port selfupdate
$ sudo port upgrade outdated
$ sudo port upgrade imagemagick

The last gives:

--->  Activating perl5 @5.12.3_1+perl5_12
Error: Target org.macports.activate returned: Image error: /opt/local/share/man/man3p/App::Prove.3pm already exists and does not belong to a registered port.  Unable to activate port perl5. Use 'port -f activate perl5' to force the activation.
Error: Failed to install perl5
Log for perl5 is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_lang_perl5/perl5/main.log
Error: The following dependencies were not installed: perl5
Error: Problem while installing glib2
To report a bug, see <http://guide.macports.org/#project.tickets>

Following the suggestion there I ran $ sudo port -f activate perl5 but this yielded:

--->  The following versions of perl5 are currently installed:
--->      perl5 @5.8.9_0
--->      perl5 @5.12.3_1+perl5_12
Error: port activate failed: Registry error: Please specify the full version as recorded in the port registry.

At this point I'm at my wits' end, so any help is much appreciated!

share|improve this question
    
What does /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_‌​release_ports_lang_perl5/perl5/main.log show as the error? –  Mark Dec 17 '11 at 16:19

1 Answer 1

up vote 3 down vote accepted

Their migration page should cure all of your ills.

share|improve this answer
    
Thanks, that worked! I had to run sudo port -f activate perl5 after taking the steps there again, but this time it didn't yield the above errors, and after that ImageMagick installed fine. –  tog22 Dec 20 '11 at 16:13

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.