Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I have a first generation Macbook Air, and the firmware is locked. I tried taking it to an Apple store, and they recommended swapping the Logic Board. Is there anything I can do to reset the password?

share|improve this question
    
Unfortunately, Apple's online support article (support.apple.com/kb/TS2391) simply states to schedule an appointment at an Apple retail store or an Apple authorized service provider. –  bneely Dec 16 '11 at 1:00
    
What do you mean by "the firmware is locked"? Do you mean an EFI password, or something else? –  Daniel Lawson Dec 16 '11 at 3:58
    
It can't boot off the hard drive, or any other device for that matter. Holding down the Option key brings me to a prompt with a lock pad asking for a password. –  Connor Dec 16 '11 at 4:26

1 Answer 1

I've solved it using MacOS installer. There is 'Firmware password' application in Utilities (top menu). Just use it.

share|improve this answer
    
In order to boot to the Installer though you have to either set it as the Startup Disk via System Preferences in your OS or you have to boot to it using a modifier key at startup. The firmware password prevents modifier keys from working unless you enter the password. From the sound of it his machine isn't booting to his OS for whatever reason so the System Preferences option would be out as well. The usual hardware tricks to get around a firmware password are also unavailable with it being a MacBook Air. –  Mr Rabbit Mar 25 '13 at 16:03

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.