Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Possible Duplicate:
When opening a DMG file, how do I get it to open up in front of the windows?

Whenever I open up a .dmg file, it just gets opened, but it stays under everything that I've got open.
Right now I would have to launch Mission Control to see the opened .dmg window and then click on it, to become visible at the top.

How can I set it up to behave in a way, that when I open up a .dmg file, it gets displayed on top of everything?

share|improve this question

marked as duplicate by Nathan Greenstein Dec 15 '11 at 17:37

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1 Answer 1

up vote 0 down vote accepted

That's a Finder (on Lion) issue and as such, there are no settings to tweak for your problem. A faster way to reach the mount window is to simply click the Finder icon in your Dock.

share|improve this answer
    
Thanks for the answer. So you wanna tell me the devs didn't think that a .dmg that i WANT to open , should be in the front for me to see after I click it ?? And rather have me going to some other place first, even if I clicked the icon so I can install it ?? –  1amtoo1337 Dec 15 '11 at 14:51
    
Not really, I would consider it a Lion related bug. A dev overlook. –  yusf Dec 15 '11 at 15:00
    
Ok. I hope I can find a fix for it. –  1amtoo1337 Dec 15 '11 at 15:11
    
This isn't a Lion bug, this issue was in Snow Leopard too. –  pt2ph8 Dec 15 '11 at 15:57
    
Only in Lion for me. –  yusf Jan 3 '12 at 12:50

Not the answer you're looking for? Browse other questions tagged or ask your own question.