Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Recently (and only while at work) my phone has started to claim that its 8 hours ahead of the correct local time (e.g. it is currently a little after 1230 and the iPhone is showing a little after 2030).

If I disable automatic time setting (Settings > General > Date and Time > Set Automatically) and manually confirm my location, all is well and the iPhone shows 1230. (Location services are switched on.)

enter image description here

Of course, this isn't sustainable because I'd like my phone's time to be kept in sync.

From researching a little it seems as though this is a carrier related problem, can anyone confirm that?

Update: After discussing the issue with my carrier's helpdesk they confirmed a problem with one of their cells which they subsequently fixed and which caused my timing issue to go away.

Moral of the story: it's not always something that you can fix by yourself!

share|improve this question
    
Perhaps you could accept some of your answers, this would encourage more answers. Can you also make sure you are in the correct timezone? under set automaticly –  Graeme Hutchison Dec 15 '11 at 12:43
    
Perhaps I'd accept some answers if they'd actually answered the questions? I'm not going to accept an answer that didn't help just to bump my acceptance rate. –  Unsliced Dec 15 '11 at 13:01
    
And when you enable 'set automatically' it doesn't tell you which zone you're in - that area goes blank. –  Unsliced Dec 15 '11 at 13:01
    
are location services on or off? –  Graeme Hutchison Dec 15 '11 at 13:05
    
Location services are on. –  Unsliced Dec 15 '11 at 13:08

6 Answers 6

up vote 2 down vote accepted

You should see the Location you are in under the set automaticly button. As below. It is greyed out, as this is taken from your current location, so you must have location service enabled.

enter image description here

share|improve this answer
    
I have location services enabled - but I don't see the greyed out location when set to automatic ... –  Unsliced Dec 15 '11 at 13:11
    
if you remove automatic and select the location you are in, then go back to automatic, does this change anything? –  Graeme Hutchison Dec 15 '11 at 13:14
    
No - it resets the time back to local+8 hours ... –  Unsliced Dec 15 '11 at 13:18
    
in that case you could try a network reset (Settings -> General -> Reset -> Reset Network settings) or check the time on the computer it was last synced to, if this computer is out then the phone can be out as well. –  Graeme Hutchison Dec 15 '11 at 13:24
    
Hmmm. The machine is syncs to is fine and a network reset will wipe all the WiFi settings, too. I'll try it if I know it will work, but that's a big gamble otherwise. –  Unsliced Dec 15 '11 at 13:32

I just had this problem and resolved it. My iPhone thought it was in New York when it was in Abu Dhabi.

Go to Settings > Location Services > System Services

System Services is the last item on the Location Services page. Scroll all the way down and tap it.

Inside System Services, there will be options for: Cell Network Search, Compass Calibration, Diagnostics & Usage, Location-Based iAds, Setting Time Zone, and Traffic.

On my iPhone, Setting Time Zone was switched off. I turned it on and voila! I now have the correct time zone.

I may have turned off location services when I was trying to troubleshoot battery life under iOS 5 and forgotten to turn it back on.

I hope this is helpful.

share|improve this answer

Try to reset Settings > General > Reset > Reset Location Warnings.

share|improve this answer

We're looking for long answers that provide some explanation and context. Don't just give a one-line answer; explain why your answer is right, ideally with citations. Answers that don't include explanations may be removed.

I've had this problem too. The settings seemed to change when i entered my WiFi network at home. I resolved this simply by entering Settings -> General -> Date and time -> (uncheck)Set Automatically. I then entered my timezone, and boom, problem solved!

Hope it helped :)

share|improve this answer
    
I mentioned doing this in the question - disabling 'set automatically' is not a sustainable solution as I want it to automatically update its time. –  Unsliced Jan 12 '12 at 10:24

I had that issue too; it went back to normal after a sync with a PC.

share|improve this answer
    
A sync hasn't helped - and it doesn't do this at home, just at work! –  Unsliced Dec 16 '11 at 9:37

I found that calendars had time zone support on, which means all times are shown at that time zone, instead of the time zone of the current location. To turn it off, go to Settings>Mail,Contacts,Calendars>Time Zone Support>Off

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.