Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I have an iPhone 4 running iOS 5.

In the last month or so, it has developed an annoying habit. When a new mail arrives it makes a "boing" sound and a vibrate.

It does this, even though the New Mail sound setting in Settings is switched to None. It does this, even when all sounds are switched off, via the mute button!

It is very annoying! Does anyone else see this bug, and does anyone have a suggestion (short of a clean install) to fix it?

share|improve this question
    
Is there somewhere a listing (for iOS5) of sounds that will be heard even when the sound switch is "off"? I got one the other day, I think. This could be embarrassing if it happens in a setting where you want quiet! –  GEdgar Dec 15 '11 at 15:31
    
It's infuriating! I don't know how to switch it off - have tried everything!! –  dan8394 Dec 15 '11 at 23:34
    
have you tried a factory reset? –  Graeme Hutchison Dec 17 '11 at 10:43
    
Reset network settings. This has been causing trouble for other strange behavior aswell. Are you using push for that mail account? –  gentmatt Dec 17 '11 at 10:47
1  
Folks - please post your answers as answers. I cannot award the bounty to a comment. In this case, though - it looks like Griffo's solution has fixed my problem. –  dan8394 Dec 17 '11 at 12:35
show 1 more comment

7 Answers

up vote 8 down vote accepted
+250

I had this problem. It was caused by the Gmail app. If you have it installed, go to your phones Settings and find the Gmail app in the list. Turn off Sounds and that should fix your problem.

share|improve this answer
1  
I think this has fixed it! Thank you very much Griffo. I'll just wait a little while to verify that it has sorted it before giving you the bounty ;-) but it is looking promising. –  dan8394 Dec 17 '11 at 12:34
    
Griffo: I have Gmail on my iPhone, but only the Calendar is active. Still, I get the incoming e-mail alert sound when the mute switch is "off." I realize I can shut off the alert sound by setting it to "none" in Settings->Sounds, but what if I want the sound most of the time and only want it muted when the mute switch is "off?" Is this still Gmail? If so, where do I find the "Sounds" that I'm supposed to switch off? Thx! –  user18752 Feb 15 '12 at 4:42
    
Peter, the mute switch should mute everything except alarm sounds. If that's not the case then it sounds like a problem with your phone. Is it jailbroken? –  conorgriffin Feb 15 '12 at 10:36
add comment

I found the solution on my IPHONE4 (IOS 5) here:

Settings --> Sounds -- New Mail -- and set it to "NONE" ... :)

share|improve this answer
3  
The OP (obviously) already tried that, he said it in the question. –  Loïc Wolff Jan 3 '12 at 13:41
add comment

I had the same problem. It turns out it has to do with jailbreak and lockinfo. In lockinfo, go Plugins -> ail -> (New Mail Alert) Repeat Duration, and set it to "None".

share|improve this answer
add comment

None of the proposed solutions in this thread have worked for me. My setup is a mail account connected to a corporate Exchange server, plus Gmail synced to the phone via the Exchange protocol, with emails unselected in that profile. In addition, I have the Gmail app installed.

I use this setup because it lets me easily separate work email from personal email.

I have found that there are three places to possibly disable New Mail sounds in this setup:

  • Settings -> Sounds -> New Mail
  • Settings -> Notifications -> Mail
  • Settings -> Notifications -> Gmail

Even after setting all three to play no sounds, I am getting the default "Ding" sound whenever email arrives from my corporate Exchange server. When emails come in from Gmail, they honor the Gmail notification setting.

My first attempt at a solution was to uninstall the Gmail app completely. Even after doing this, I still got the annoying Ding sound every time an email came in.

Next, I completely removed the Gmail account from the phone. So no Gmail app and no Gmail connection in Settings -> Mail, Contacts, Calendars. Still no solution: Every time I got an email from my corporate Exchange server, my phone made the Ding noise.

Next, I decided to do a cold reset by holding down the power and home buttons. After doing this, the sound finally went away!

I added my Gmail account back to the phone (still no Gmail app), and did not select the Mail sync option. The sound was still gone!

Finally I re-installed the Gmail app. Settings -> Notifications -> Gmail -> Sounds On. Email from corporate Exchange is still silent! Email from Gmail is making sounds just as I have configured it.

So it's hard to say exactly what fixed it. Maybe it was the cold reset. Maybe it was the uninstall/reinstall. Maybe it was the combination of everything. But the important part is that this process worked for me, and I hope it works for someone else as well.

share|improve this answer
add comment

Here is how I stopped email notifications on iPhone 5.

I turned off notifications in:

  1. Settings -> Sounds -> New Mail -> Alert Tones -> None.
  2. Settings -> Notifications -> Mail -> iCloud -> New Mail Sound -> None.

This alone did not work, so I also turned off the iPhone and subsequently turned it back on, and it worked.

I don't have Gmail, so I didn't address that.

share|improve this answer
add comment

I went to Settings.app, then to Gmail, and it directed me to go to "Notifications", which I did. I then went to Gmail and turned everything OFF. This worked correctly.

share|improve this answer
1  
The settings your referring to address the Gmail stand alone app. I believe the OP is referring to the built in Mail App. –  jbharper2 Dec 12 '12 at 5:55
add comment

I dont have Gmail but Yahoo and its the same DING problems...NOW SOLVED

as mentioned before Settings -> Sounds -> New Mail Settings -> Notifications -> Yahoo

...are the 2 areas you can change the sound to NONE and hope for silence, STEP 1....CHANGE TO NONE as you would STEP 2....TURN OFF THE PHONE

I found this out after going thru this thread and especially trevorsky's great input...

as I let the phone simmer for 10 ish seconds, I turned it back on and test tried sending myself emails from my laptop and see phone's response...sweet sweet sound of silence

share|improve this answer
add comment

protected by gentmatt Jan 24 '13 at 11:33

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.