Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

MacBook Air 11" - Mid 2011

My MacBook is not reconnecting to the wireless network on wakeup.

Is there a setting or something that I'm missing?

share|improve this question
    
Not going to add it as an answer as I haven't experienced it myself, but Dan Benjamin on The Talk Show podcast said that he had the same thing, it drove him mad, until he removed Bluetooth from the Network Preferences panel. Apparently if you need Bluetooth, you can also make sure it's listed below wifi in the order of network adapters, and that works as well. –  nthonygreen Dec 13 '11 at 15:20
    
I tried this but, i am also asked for the wireless password on every attempt. It does not even "remember" it. It's sooo sad :( –  Herr K Dec 13 '11 at 17:18

4 Answers 4

Are you running the latest version of Lion?

If so there is a "known" issue with this - my older Macbook will wake from sleep and connect to the wifi. A few seconds later the connection will be dropped until I reselct the network.

I've tried various resets and plist deletions with no joy, and know several other people with the same issues.

I'm hoping for a fix when the next update comes around.

share|improve this answer
    
Oh.. I didn't know this :) Let me check that. Yes Lion with latest version :) –  Herr K Dec 13 '11 at 13:15

I've been having a problem where WiFi will not reconnect on wake from sleep - in my case the Time Machine icon is spinning as if it were running a backup. If you cancel Time Machine's backup job, WiFi will instantly re-establish itself when Time Machine finally stops processing.

It seems to be some sort of bug related to putting the Mac to sleep while Time Machine is attempting to do... something... to the Time Capsule hard drive.

share|improve this answer
up vote 1 down vote accepted

SOLVED!

Solution:

The network i was trying to connect to, was set not to distribute it's ID, so i typed it in or saved it somehow at some point. The fatal error is, the SECURITY TYPE does not match with the wireless router so every time, the computer ask again for the correct type/key combination resulting in, a disconnection from the wireless network :)

To fix it, go to Preferences > Network > Advanced and press the plus sign and ADD THE ENTRY MANUAL!!!!!!! and you will be fine.

Hope it helps, thank you all!

share|improve this answer
    
Just recommended this fix to a friend who saw the same thing on a brand-new Mac mini - removing BT from Network services worked for him as well. –  da4 Feb 15 '12 at 14:10
    
God sent you :D I had forgotten how to fix this (chaged the SSID:D) now i need to do it again. Thank you! –  Herr K Feb 15 '12 at 18:12
    
Manually typing in my network credentials and replacing the current network when prompted, did the trick in my case. Thanks so much! –  user81511 Jun 12 at 4:44

Every time MacBook Air (2010) waked-up from sleep it would ask to choose network to re-connect and then took about 20 sec to actually connect. same if I turn wifi off and then on again.

solution that worked for me was: system preferences -> network -> SET SERVICE ORDER.." (in sub-menu next to "+"/"-" (create/remove service) at the bottom of services list on the left).

DRAG WIFI TO THE TOP in Service order list -> "OK" -> "APPLY"

After that I am back to no "choose network to connect" pup-up's and wifi connects in 3 seconds. Hope that helps.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.