Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I use three keyboard layouts (three input sources), and I chose to show the source in the toolbar (I mean the main bar at the top).

Since I moved to Lion, in addition to the icon for the input source (usually the flag of the country speaking that source) it also shows the name (which takes a lot of precious space). I choose the "Hide Input Source Name" from the menu and the name goes away until I reboot.

Any solutions?

share|improve this question
1  
Have you tried rm ~/Library/Preferences/ByHost/com.apple.HIToolbox*? –  ؘؘؘ Dec 11 '11 at 12:50

2 Answers 2

Another thing you could try would be to lock ~/Library/Preferences/com.apple.menuextra.textinput.plist in Finder. (OS X performs atomic saves on preference files so chmod 600 wouldn't work.)

At least on my account the file contains just a ModeNameVisible key:

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
    <key>ModeNameVisible</key>
    <false/>
</dict>
</plist>
share|improve this answer
    
thanks, It was locked already but I now made it read only, let's see what happens. –  Ali Dec 14 '11 at 23:34
    
Nop! comes back again! even when locked and I have only read access! –  Ali Dec 16 '11 at 13:27
up vote 0 down vote accepted

As suggested by @Lri
rm ~/Library/Preferences/ByHost/com.apple.HIToolbox*

works, but you need to get the order right, first make sure the label is not showing "Hide Input Source Name" then remove the files as suggested, I guess it is also necessary to restart as well, then add the keyboards (input sources) back.

But it comes back!

This is a bug or something,

For the record I am using Dvorak-Qwerty
U.S.
Persian

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.