Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I have a MacBook pro running Lion. Usually, I need to run tasks that takes hours... so I just leave the laptop working before going to bed.

When I wake up, I notice that it tried to shutdown the system. How do I notice this? Well... all apps are closed except for iTerm (which always stops shutdown process when there is more than one tab open).

I tried to search the energy saving settings but there is nothing related to this... I would like to see how to prevent this behavior.

share|improve this question
add comment

1 Answer 1

  1. Make sure your power adapter is connected to the Mac while you are sleeping.

  2. In the Power Adapter section in Energy Saver, make the "computer sleep" -> "never".

  3. You don't want your screen is on when you are in bed right? So make "Display sleep" -> some minutes.

  4. Uncheck "Put the hard disk(s) to sleep when possible" and "Restart automatically if the computer freezes".

That should work!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.