Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

When playing Minecraft 1.0, a java-based game, when I switch the rendering options to "Far", the game shows a message saying that memory usage for the game might be too high in Far rendering mode, and that I'm running 32-bit java and should install 64-bit java for the Far mode to work properly.

I can't recall ever actually installing java on this Mac at all.

Is there a way for me to install 64-bit java on my Mac?

This is an June/July 2011 iMac with Mac OS X Lion, all updates installed.

share|improve this question
add comment

3 Answers 3

up vote 4 down vote accepted

Look for Java Preferences in Utilities. There you'll find order of Java binaries browser will use.

share|improve this answer
1  
Thanks, that answers my question but raises some new ones. The order was 64-bit first, but Minecraft still runs 32-bit. I guess I'll have to see if there's anything special about Minecraft that picks the 32-bit then. –  Lasse V. Karlsen Dec 6 '11 at 15:21
add comment

Here's a well-written and detailed discussion about Minecraft & Java including Java order, the Minecraft start stub, etc:

Make sure to use the latest Java: Java for OS X Lion Update 1 (Java 1.6.0_29, updated 09. Nov.) Java for Mac OS X 10.6 Update 6 (Java 1.6.0_29, updated 09. Nov.) Java for Mac OS X 10.5 Update 10 (Java 1.6.0_26 on 64bit Intel, Java 1.5.0_30 last release for PPC) Java for Mac OS X 10.4, Release 9 (only supports Java 1.5.0_19)

At this point it's a good idea to open Java Preferences and check which versions of Java are installed and what the preferred run order is. Sort it so that Java 6 64bit is on top, then Java 6 32bit, Java 5 64bit, Java 5 32bit.

Within Info.plist (see paragraph 2), find the 'JVMVersion' key and change it to '1.6+'. The next step is to replace 'JavaApplicationStub' in

Minecraft.app/Contents/MacOS/

with the one found in

/System/Library/Frameworks/JavaVM.framework/Versions/A/Resources/MacOS/

Use 'Show package contents' and 'Go to folder' (⇧⌘G) to find those places.

Most people experience improved performance when switching to 64bit. Add a key to 'JVMArchs' with the value 'x86_64' on top of the existing ones to run Java in 64bit if it is available. This step is optional but recommended.

share|improve this answer
add comment

The problem is in the Minecraft launcher itself. I checked it out:

$ cd /Applications/Minecraft.app/Contents/MacOS
$ file JavaApplicationStub
JavaApplicationStub: Mach-O universal binary with 2 architectures
JavaApplicationStub (for architecture i386):    Mach-O executable i386
JavaApplicationStub (for architecture ppc): Mach-O executable ppc

So I figure if we put in a 64-bit JavaApplicationStub it will work.

I'm not sure if a newer Minecraft launcher fixes the issue because mine was downloaded pre-1.0.

share|improve this answer
    
Even adding in the line of code for 64 bit (identical to the bottom two lines, but replacing ppc or i386 with x86-64) manually or with X-Code and replacing the JavaApplicationStub in the MacOS folder of the Launcher (visible after viewing package contents of the Launcher) isn't enough to kick it into gear. My java preferences had 64bit on top by default also. I'm going to redownload the Launcher from Mojang and see if it is simply that we've been using versions that refuse to let this work for some reason or another. –  user18235 Feb 4 '12 at 14:58
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.