Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

The times in my iCloud calendar are all wrong.

The answer I found to fix this is to click on my name in top right hand corner — only problem is that my name does not appear there and I can find nowhere to access settings for the time zone.

iCould currently shows "Pacific time zone" and I need it to be set to "Australian Eastern Summer time".

share|improve this question
add comment

2 Answers 2

I suspect you missed a step on the answer you were looking at - you should be doing this on the iCloud site, not in iCal.

Goto iCloud.com, log in, then you should see your name in the top right corner: enter image description here

Click there, and you should get an account preferences pop-up where you can set your time zone info:

enter image description here

share|improve this answer
add comment

You can log into iCloud.com and go to the iCloud start page by clicking on the cloud icon in the top left corner of your screen. iCloud will remember the last web page you visited and it won't bring you to the start page on startup.

Once you are in the start page, you can click on your account name in the top right corner of the screen. That brings up a dialog box where you can specify your iCloud account's time zone. Hope this helps.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.