Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Possible Duplicate:
How to turn off the iOS-style character picker menu

When I am writing and I hold number pressed, as when you write the number 9999999999, a dialog appears.

It ask me wether I want to write 9ª or 9º. I want none of them, I just want to write the number.

This is very annoying, how can I deactivate this behaviour altogether?

share|improve this question

marked as duplicate by patrix, Nathan Greenstein Dec 4 '11 at 17:13

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
Are you on Lion? Is this the feature whereby if you hold down 'e', for example, it pops up a dialog that lets you pick accented versions of 'e'? There's a possible answer in this question. –  Dan J Dec 3 '11 at 20:12
add comment

1 Answer 1

You need re-enable key repeat for this context menu to go away. It'll affect character keys as well as number keys.

  1. Open Terminal.app
  2. Enter the following to turn this context menu feature off and reenable the old key repeat behaviour: defaults write -g ApplePressAndHoldEnabled -bool false

And you're done. Holding down any key now should repeat that key in the text entry window instead of calling up that context menu to select alternate characters.

To turn the context menu feature back on enter: defaults write -g ApplePressAndHoldEnabled -bool true instead.

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.