Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I have an Apple Magic Mouse, and in Safari, when I swipe my fingers left and right on the mouse, first the page scrolls left or right if there is a horizontal scrollbar, and then if there is no scrollbar or the scrollbar is already at the edge, then Safari will go back/forward in my history.

This is particularly annoying when I am trying to scroll left / right, and accidentally scroll too far and navigate off the page.

For example, if I'm answering / editing a question on StackOverflow which has

some really long code block example which is so wide it gets a horizontal scroll bar or the text area has a scroll bar
some really long code block example which is so wide it gets a horizontal scroll bar or the text area has a scroll bar
some really long code block example which is so wide it gets a horizontal scroll bar or the text area has a scroll bar
some really long code block example which is so wide it gets a horizontal scroll bar or the text area has a scroll bar

if I quickly swipe left / right to read the code, I often accidentally leave the page I'm on.

Can I disable the "swipe to navigate" back / forward function of Safari? I only want to use swiping to scroll, not to navigate.

share|improve this question
add comment

2 Answers

up vote 22 down vote accepted

Look under "More Gestures" the "Mouse" System Preferences pane: Screen capture of the "More Gestures" panel

Set it to two fingers or disable it altogether.

share|improve this answer
2  
I feel so stupid now. I swear I looked for this before and couldn't find it! Thanks! –  Josh Dec 2 '11 at 0:28
    
is there a way to disable this on Safari only? I like this behavior on all other apps (Preview for example) –  whaley Feb 29 '12 at 21:08
    
Without a third party app, no. Check out BetterTouchTool it might be able to do this. –  Kassym Dorsel Mar 1 '12 at 20:50
1  
Darn. Its too bad that you have to turn off the feature all together. Its a useful feature for when reading ebooks or pdfs, but an EXTREMELY annoying feature in safari. Anyone know of another solution? –  user20213 Mar 16 '12 at 4:56
1  
It's worth clarifying that this solution also works for the same problem in Chrome (and probably other browsers too, although I haven't tested that). –  Andrew Ferrier Dec 17 '12 at 16:23
show 2 more comments

BetterTouchTool is a free solution: it lets you set up multi-touch gestures differently between different applications. I've had no issues using it yet, although I've only been doing so for a few days and only on Lion. It has received a respectable bunch of positive mentions from places like TUAW, MacWorld, and Lifehacker, and the only less-than-great reviews I've been able to find for it seem to be along the general lines of "I wish it also brushed my teeth" and "I turned off $feature and $feature stopped working"

Personally, it has saved my MagicMouse from the ignominy of sharing duty and mousing space with a wired Mighty Mouse.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.