Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I got a new iPhone 4S, but I had upgraded my old iPhone 4 to iOS 5. I want to give it to my brother. But on wi-fi, I get iMessages on both the phones. I want them to come only to my 4S and not to the old one.

share|improve this question
add comment

1 Answer 1

Under Settings > Messages > Receive At, remove your email address, you should then only receive the messages on your iPhone 4S.

You can also, set up a new Apple ID for your brother. He should then be able to receive iMessage on both his phone number and his email address.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.