Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I've followed the advice in these questions and am not having any luck. No matter what I try, the fonts are rendered so poorly on the external monitor.

My environment -

  • MacBook Pro 15" Early 2011
  • ViewSonic VX2450 External Monitor using DVI.

I've tried values for "X" (0,1,2 and 3) for this command without effect --

defaults -currentHost write -globalDomain AppleFontSmoothing -int X

I've also tried each of these values along with various combinations of values for "Use LCD font smoothing when available" and "Turn off text smoothing for fonts sizes X and smaller" in System Preferences > General. All without any luck.

Can anyone offer me some advice? Thanks!

share|improve this question
add comment

2 Answers 2

A couple things to consider:

  • Do you see a difference with the various AppleFontSmoothing settings on your main display?
  • Are you seeing this in all apps, or just one or two?
    • Some programs render fonts independently of the OS, so changing the global font smoothing won't make a difference in them
  • What is the physical connection between the MacBook and the Viewsonic?
    1. mDP to VGA adapter?
    2. mDP to DVI adapter?
    3. mDP to HDMI adapter?
      • Analog signals on VGA might not support the resolution
      • Make sure any OSD controls for the port you're using have the correct settings
  • How have you configured the Viewsonic, relative to your MacBook's main panel?
    1. Mirroring the internal display
      • Select a resolution for your main display that is an even factor of your Viewsonic's native resolution
    2. Set as its own independent display
      • Choose the Viewsonic's native resolution

Hope one of these leads you down a path that ends in a pretty picture.

share|improve this answer
add comment

Are you sure it's font smoothing that is to blame? I had a similar issue that was caused by trying to use a resolution which was available in my displays preference but higher than my monitor supported.

Even though your monitor is rated for 1080p try a resolution with less than 1080px height. There's a possibility that you won't be able to get full 1080p through DVI (will explain further if the lower resolution solves it).

Also note that the same thing can happen when you use non-native resolutions that require scaling, not just larger ones.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.