Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

My MacBook Air from mid 2011 recently only scores about ~1800 on geekbench vs 5300+ that it was before. I'm starting the benchmarking right after reboot, and the CPU seems initially calm. Any points?

share|improve this question
    
What version of OS X are you running? –  cksum Nov 28 '11 at 17:18
    
If you dig into geek bench a bit, you should be able to figure what part of the test is lagging and make guessing the cause a bit easier. Also, do see about checking the temperature of the internals using hardware monitor software since the system will slow the CPU when it's sensing temperatures towards the higher limits for each model to avoid damaging the hardware. –  bmike Nov 28 '11 at 17:26
    
I'm on 10.7.2. The first thing I checked out this morning was running geekbench while the computer was still cool after sleeping - same result: 1867 points. Also, I found a reference to a command that supposedly gives the actual CPU speed: sysctl hw.cpufrequency, and it showed hw.cpufrequency: 1800000000. –  nomadcoder Nov 29 '11 at 3:52
    
bmike, the exact slow tests are Integer and Floating Point operations. –  nomadcoder Nov 29 '11 at 3:53

3 Answers 3

up vote 6 down vote accepted

I went to the Apple Service, where the guy has booted from an external hard drive and run the Repair Disk Permissions task from Disk Utility. That solved the issue!

Note: I did run Repair Disk Permissions before while trying to solve this problem, but it apparently couldn't fix some of the files due to that the disk was mounted. So, booting from an external disk is crucial here.

share|improve this answer
    
UPDATE: Having the same symptoms again (I suspect it was caused by my accu running empty while the laptop was doing something), this time this recipe doesn't work: the permissions just stay not repaired - that is, running Disk Utility reports the same errors over again. This time found no better way than reinstalling Lion. –  nomadcoder Mar 26 '12 at 8:55

Alright, another solution that worked for me. Got the same symptoms, but nothing helped this time, including my own original recipe (the one marked as the accepted answer).

Long story short: resetting SMC did the trick - http://support.apple.com/kb/HT3964?viewlocale=en_US&locale=en_US

Just FYI, this time I tried the following before coming across the SMC reset trick:

  • Fixing all permission problems, including manual removing ACL on some system files.
  • Restoring from TimeMachine.
  • Clean reinstall of Lion.
share|improve this answer

Perhaps there is a background process that is taking away some of the processor's powers. Did you check in Activity Monitor if there was a process that took more than say 10 or 15% for no reason? Make sure the "Show All Processes" is selected.

And perhaps a bit of maintenance with apps like Onyx, CleanMyMac or Cocktail is in order. Never a bad thing to do...

share|improve this answer
    
Yes, I carefully checked to made sure the processor was close to idle. I tend to agree with bmike that something unnecessarily slows it down. –  nomadcoder Nov 29 '11 at 3:44

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.