Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I keep getting this message:

"Wi-Fi has the self-assigned IP address 169.254.10.243 and will not be able to connect to the Internet."

I was connected and my Wii and iPhone were using Wi-fi through my Airport card. I tried to set up a new network, but it won't connect with it.

How do I get rid of the self-assigned IP address? I have rebooted everything. I also dumped files from the library that a help group told me to do:

  1. Go to /Library/Preferences/SystemConfiguration
  2. Delete the following:
    • com.apple.airport.prefrences.plist
    • NetworkInterfaces.plist
    • Preferences.plist
  3. Shut down computer
  4. reset PRAM

I changed the channel to a lower number. Any suggestions? I have an iMac.

share|improve this question
    
Did you reboot the WIFI modem? –  Macconsultant Mar 28 '12 at 18:35

4 Answers 4

It sounds like you were sharing your ethernet internet connection with your Wii and iPhone via your internal Airport card. The wireless strength indicator in the Menubar on your Mac should have a little arrow pointing up if this is your situation. Check System Preferences/Sharing/Internet and make sure you are still setup to share your ethernet connection via Airport. Also make sure you ethernet cable is still plugged in.

share|improve this answer

Pay your wireless bill? :-0 Just kidding..

So, the Wii still gets on the Internet and surfs no problem, but the iMac and the iPhone are unable to connect to the same network?

The self-assigned address happens only when the machine is unable to get anything else from DHCP. It usually means that the Internet Modem has failed or Internet from your ISP is not getting to you properly.

But, if the Wii can surf the internet and pulls a proper address and is working fine, it's gotta be something else.

Do you have a router that is only giving out 1 address? Meaning that if you turn the Wii OFF, can your iMac then connect to the wireless network and pull a valid address, and then surf the Internet again?

share|improve this answer

Delete the entry in network connections for your wireless router and re-add it. Also delete any entries for using your iphone/wii through your wifi card. Your iphone can connect to the router directly. Why use the iphone? Your wii also has wireless so don't see why you'd do that either?

share|improve this answer

Have you tried a force shutdown? (hold power button) I've had a similar problem with my Mac mini before and that somehow fixed it.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.